Connect to WPA2-Enterprise

My Router has internet connection.
I'ver read through forums with "installing wpad", but it say, i already installed it. I still cant connect to a wpa2-enterprise wifi. Am I doing something wrong?

I tried it with putty, like in this article:

But when I use the command "/etc/config/wireless" I get the following:
image

If you just type the name of a file it will try to execute it instead of edit it. Though the standard vi text editor is included in OpenWrt, it is not very simple to use. Most people would install a text editor package such as nano, then nano /etc/config/wireless

Another approach is to scp the file from the router to your PC, use your favorite PC text editor, then scp the modified file back to the router. When doing this on a Windows PC make sure the editor is set up for UNIX line endings, not DOS.

1 Like

But is there a way to do everything with luci?

Yes you should have the Enterprise options (EAP etc) in the Wireless Security tab. If this does not appear, clear your browser cache and reboot the router as was in this thread: Installed wpad but cannot choose/find WPA-EAP

I'm strictly a CLI user but it is supposed to work in LuCI.

1 Like

Okay, thank you. I'll try that!

Release builds come with wpad-mini or wpad-basic (use opkg list-installed, or the Luci software page, to see what is installed). You have to remove the mini or basic version before the full version can be installed. If you just go directly to install wpad, it will fail to install, with a file conflict error.

It is OK to remove wpad-* while your Internet connection is wifi (thus using wpad)-- though if you reboot with no wpad you're stuck.

1 Like

Well, lets just say the reboot fixed it :sweat_smile: