Connect router to ethernet wall socket

Hello world,

when I plug in my notebook directly into the Ethernet-socket located in my wall (student dormitory) I have internet. Because I want to use it wirelessly, I successfully installed OpenWrt on my Router (o2 Box 6431) and set the wifi up.

When connecting the router (port: DSL (=WAN?)) to the wall socket via a Ethernet-cable, I cannot login to the internet. Unfortunately I do not know which settings I have to change in order to achieve this. Does anyone know what to do? :slight_smile:

Thank you very much!

btw: I used the firmware:
openwrt-18.06.1-lantiq-xrx200-arcadyan_vgv7510kw22-brn-squashfs-factory.bin

For Starters DSL is not Ethernet, so disconnect the DSL from the wall Ethernet.
Then get yourself a LAN cable (Ethernet cable) to connect one of the LAN ports (and refer to it as WAN port from now ON) to the Wall Ethernet port.

But before you do that you need to configure your new WAN port as a WAN port.

1 Like

Thank you for your answer.
I tried it via connecting the Ethernet-cable from LAN1 to the wall. However, I don't now how to set everything up in the web interface. The link you have posted has this answer:

How can I do this in the web interface?

Network->switch
And
Network->interfaces

Yes, I got that. Unfortunately there are many possibilities, and this descrption is somewhat cryptic.

  1. in Network->switch delete the 1st row (port 1), in the remaining port 2 select CPU as "tagged". save and apply.

  2. a new interface was not created, when I switch to Network->interface. there is still LAN (green), WAN (red), WAN6 (red)

(image was created before I deleted the 1st row)
Screenshot%20from%202018-08-31%2020-37-53

The o2 Box 6431 wiki article suggests that the WAN port can be used as either DSL or Fast Ethernet. I cannot verify it since I don't have this box.

Let me try to explain how the switch configuration dialog works.

Each row refers to a VLAN, with its ID in the first column. In your screenshot, there are VLAN 1 and VLAN 2. Not explicitly shown is the fact that VLAN 1 is used as LAN, and VLAN 2 is used as WAN/WAN6.

Each column refers to an ethernet port. The CPU(eth0) port is special because it does not lead to a physical socket on the outside. Rather, it stands for the internal connection between the CPU and the built-in ethernet switch.

To change the VLAN assignment of a port, find the port's column and the VLAN's row. Click on the drop-down at their intersection and choose the new value. Repeat for other VLANs until done, then click Save & Apply.
For example, to remove Port 4 from LAN and assign it to WAN, set it to off in the first row, and to untagged in the second.

If you want to experiment further with VLAN settings, I would suggest to follow these rules:

  • Don't delete either VLAN 1 or VLAN 2. You can add further VLANs and delete them again as needed.
  • Set all cells in the CPU(eth0) column as tagged.
  • For VLAN experiments, it is best to manage the router over a wireless connection. If you manage it over wired ethernet, don't change this particular port's VLAN settings.
  • Each of the remaining ports should have exactly one VLAN set to untagged, and any others set to off. Don't use tagged on them for now.

It's not necessary to create a new interface, you can reuse WAN/WAN6. Interfaces are different from switch VLANs, they are connected in the interface's Physical settings.
Check Network > Interfaces > WAN > Edit > Physical settings, then do the same for WAN6.
If you have any questions about it, please post your config here.

How does your notebook get its IP configuration? DHCP(v6)?
Is your connection locked to a single ethernet MAC address?

I'm confused

You already have a WAN port with "no link", what happens when you connect a ethernet cable to the "WAN" port does the port status change ?

Thank you @mpa for your detailed answer. I changed the switch VDSL settings (picture at the end of this post).

However I am not sure how to set up the interfaces (config file below).

I asked the company who set up the network in the student dormitory.

  • The IP adress (IPv4) is assigend by this company
  • there is no limitation in regards to the MAC-Adress
  • The router has to be ethernet-able with a configurable WAN Interface. A switch or Access-Point without routering function does not work.
  • because the Internet is provided via LAN, a DSL-router does not work
  • the o2 Box 6431 does have such an Interface, however it's firmware is without function (but this is different when using OpenWrt, right?)

Physically I have 4 LAN Ports (named "LAN1", .. "LAN4", and one "DSL" Port, all of them are Ethernet-slots. When I plug the Ethernet-calbe from the wall-socket into the "DSL"-port in my router, the WAN port stays grey without any text.

(From System→Backup\Flash Firmware, /config/network)


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3e:43de:ef3f::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'pppoe'
	option username 'username'
	option password 'password'
	option ipv6 '1'
	option ifname 'eth0.1'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr '4c:09:d4:28:8e:c2'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '1'
	option ports '6t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '2'
	option ports '3 6t'

switch

This configuration connects the LAN1 port to VLAN 2, which is commonly used for the wan interface.
VLAN 1 is not assigned to any ethernet ports.
You can now use the LAN1 port to connect the router to the wall socket, and use WLAN to connect your computer to the router. All other ethernet ports are disabled. Is this the result you intended?
I would suggest to reconfigure one of the unused ethernet ports for VLAN 1, which allows you to manage the router over a wired ethernet link in case of a WLAN failure.
By the way, the picture shows switch settings, but is not related to VDSL. The WAN port likely refers to its ethernet function only.

Because of this, I wouldn't bother with the combined Ethernet/DSL port anymore. Use one of the LAN ports instead.

How does your notebook learn about this IPv4 address when plugged into the wall socket? Do you enter the address manually, or is it configured automatically?
The wan interface in OpenWrt is currently set to protocol pppoe, which is probably wrong for a dormitory network. Reconfigure it to match your notebook's configuration when plugged into the wall socket. The likely choices are Static Address or DHCP client.

The lan and wan interfaces are both using the physical interface eth0.1, which does not work.
Change the wan physical interface to eth0.2.