Confused about wpad, hostapd and hostapd-common

Hello *,

in another thread I am using RADIUS-adjacent options in hostapd, for which I need the full hostapd binary, the stripped down one provided by the default wpad-basic multicall binary is not sufficient.

That should be straightforward to remedy, though. From a default installation, opkg remove wpad-basic-wolfssl and opkg install hostapd.

... or so I thought. Because I then still get the same error when calling hostapd as if I were using wpad-basic:

 daemon.err hostapd: Line 44: unknown configuration item 'vlan_tagged_interface'

But, and here comes the weird part, when I go and "re-install" hostapd-common:

opkg --force-depends remove hostapd-common
opkg install hostapd-common

everything starts working, and the error disappears. And for the life of me, I can't figure out why that is. "Re-installing" hostapd-common does not change the hostapd binary, hostapd-common installs the byte-for-byte identical that was installed before.

I am completely confused: What changes when I "re-install" hostapd-common? And how?

Edit: It gets weirder. If I unstall wpad-basic-wolfssl, before I install any other hostapd binary, and try to start wifi (which predictably fails), I get this in the syslog:

daemon.notice netifd: radio0 (2790): ./ eval: line 573: /usr/sbin/hostapd: not found
daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
daemon.err hostapd: Line 44: unknown configuration item 'vlan_tagged_interface'

The first line tells me that there is no /usr/sbin/hostapd, so what is the "hostapd" in the next two lines that tells me it's reading the configuration file and failing on an option?

I suppose the still running hostapd process which did not get terminated on package uninstall.

1 Like

Thank you. That was it, and it drove me crazy. Phew.

So what's the recommended action? Just a killall hostapd? The process doesn't seem to get removed any other way.