Confused about VLAN configuration?


I have a WNDR3700v2 which has been running openWRT for years. It's currently running 18.06.2, but I've for sure upgraded it a few times; the VLAN configuration I have now was done prior to the latest upgrade.

I have a network with multiple VLANs at home; I'm a networking guy, I know how they work in general, and I thought I knew how they worked in OpenWRT... but I can't seem to add any VLAN interfaces to the ones I already have!

I currently have eth0, eth0.1 and eth0.99 - eth0.1 is bridged to the wlan* interfaces, and eth0.99 is my WAN connection. I'm trying to add (for example) vlan 833 so that I can have another eth0.883 interface... but while I'm able to add the VLAN ID under Network->switch as "untagged" on port1 and "tagged" on CPU (eth0), no new interface is created... not in the GUI, and not showing up when I "ifconfig -a" at the command line.

What am I missing? I've been poking around at this for a few days, and I can't figure out what I'm supposed to do. eth0.1 and eth0.99 are there, but have been for years - why isn't eth0.883 (or any other interface) showing up?

Thanks in advance,

had a similar problem some time ago.. turns out VLAN ID number was to high.. not joking.. took me days to figure out.. try smaller numbers.. try eth0.50 insted of eth0.883..


1 Like

Not sure whether applicable but here the limit is 64, maybe depends on the switch chip.

That was an excellent guess... which unfortunately, seems wrong. Didn't work with 83, or with 22. :frowning:

Same exact problem.

Additional interfaces only appear once you start using them. Setting a new vlan in the vlan page merely programs the switch IC through swconfig. To actually get an eth0.883 you have to start using it somewhere. E.g. create a new interface and set its device to eth0.883. Once the new interface is brought up, eth0.883 will be implicitly created.


When creating a new interface, though, you need to select the hardware interface from a list, and it doesn't appear in the list, and it won't let me fill anything in under "custom"...

That sounds like a bug though. Usually you enter eth0.883 in custom and press enter, this should set the value. Maybe a browser quirk with this version of LuCI?

Just following up on this... I tried again, and it looks like the problem I was having entering in the "custom" box may have been a figment of my imagination because of all the frustration I was feeling about "why is this so hard?"

What actually happened was that it did let me enter a value, but the interface didn't actually appear until I assigned it an IP address. I haven't worked with it extensively yet, but it does actually appear to be sending traffic on VLAN 883 as I intended.

Thanks to all who helped.