Configuring SQM

I recently just got OpenWrt so I can have lower buffer bloat. I learned that SQM (cake) is one of the best QoS for this so I got it and went through the guide on setting it up but my buffer bloat is still not good, I averaged from 20-70 during my dslreports tests. I have gone as low as 10% of my max speed so I can sacrifice my bandwidth for low latency but that still doesn't help. My router is a Netgear R6220, I averaged 80/12 from dslreports with sqm off. My router is also not the main router I have a modem/router provided by my ISP, I use this router to connect to my PS4. I'm not sure if there are steps I need to do with setting up OpenWrt because this isn't my main router and if there is please let me know. Any advice on fixing SQM and lowering my buffer bloat will be appreciated.

What are your SQM settings set to and what was the result of the test?

and what medium carries your internet?

so you are saying that your PS4 is connected behind this second router with sqm?

Yes my PS4 is connected to the second router via a lan cable but i’ve just started getting NAT3 on my ps4 out of the blue so I decided to now try to set the router as a bridge (wireless repeater) and see if that helps

68,000 dl
10,500 up
cake/test_wan_triple_piece of cake
and my link layer is none

I now have a question because I just configured my openwrt router as a wireless repeater so I was wondering would it still be possible to use SQM?

My router is now a wireless repeater for my main modem/router can I still use qos on it?

put simply... not really... ( fundamentally you have some governance over link peers, but that's more than plain ol' qos/sqm )

if it routed, it's kind of more complicated than you might think...

  • how much contention upstream is there? ( are all other devices in a direct path to router1? )
  • does router1 perform any kind of qos or shaping(or is it capable of it)?

No there’s no qos settings on router 1

So sqm still runs with router2 being a wireless receiver now but it’s still very low

Very bad bufferbloat*

the only way to know is to test from a wired client on router1 to start with...

what you are seeing is likely partly airwave contention/congestion...

anyway... you won't do much with an AP downstream... unless all the other clients go through that AP too... or you have some advanced control within router1

Forget about dslreports bufferbloat test, it sucks. For the last few days I have debugged my bad bufferbloat results on that page only to find out that it dslreports is at fault. I used to get great results on that page, but since a few days the results were bad. Not sure what they changed. But I went on and used flent.

This test was done using a VDSL 100/40 line with 8 Byte overhead. First image is with qos disabled, second with cake set to 95000/30000. With no qos ping is within ~45ms - ~80ms. With cake ping is within ~44ms - 46ms. dslreports highres bufferbloat sometimes gave me worse ping results when I had qos enabled compared to when it was disabled. Cake works like a charm. I also tried fq_codel, results were not as good as with cake.

P.S. The text on the two graphs are not correct, I just didn't change the description between the tests.

You might be so right! Thank you so much I deleted sqm after getting too frustrated... what percentage of dl and up do you think will give me the lowest bufferbloat

Without qos I managed to get 100Mbps down and 32Mbps up I personally set it to 95000/30000, thus ~ 5% deducted. For me an overhead of 8 was better than 24 or 32 as recommended by some folks.

To get the most of SQM, your OpenWRT router needs to be the main router. You have to control the bottleneck (going from LAN to WAN for your case).

How do I control the bottleneck?

Make the OpenWRT router your main router.

This can be done by either:

  1. getting your own modem and taking the isp modem/router out of the equation.
  2. using the isp provided modem but not using the routing features.

So my modem/router has a wireless bridge settings in the gateway configuration... If I turn it on and apply it to the mac address of my main router will everything be good?

So right now I have my second router with openwrt set up as a wireless repeater using relayd but earlier today i went through my modem/router gateway settings and saw that there’s a wireless bridge setting? Would this setting turn off the router of my main modem/router and direct it to my secondary router?

A bridge just connects two networks and is not the same.

You are experiencing lag as your device is trying to move from gig speed (LAN) to your WAN speed. The device there is the issue. I doubt the isp modem/router has and good QoS controls. If possible buy your own modem then use your existing OpenWRT router. Likely you are paying a rental fee so this might save you money in the long term.

Placing a device with SQM after the isp modem/router is not going to eliminate your lag.