Configuring router swtich ports

Thanks a lot. I have spent a long time looking for an answer, that I cannot find.

I just installed LuCI openwrt-19.07 on D-Link DVA-G3810BN/TL.

The 'hard' ports at the back of the router work except for labelled ports 1 and 2. 3 and 4 work. That means I can connect an Ethernet cable to them and access the router. Also, the WAN port works, that means I connect that port to an LAN on my Internet router and was able to install nano.

Can someone please tell me how to configure the router so that ports 1 and 2 will work.

Present configuration is default. I have not changed anything, anywhere regarding port configuration.

I've read a lot about VLAN, but would rather get all four pots 'working' before considering VLAN options. It's a great feature, it seems. But would like to go 'old school first, before this 'new' feature.

I've read the documentation, but general as it is, does not answer my specific questions.

I thank you very much.

This device is too old already to be worthy to spend much time. But let's see quickly the
uci export network

1 Like

Thanks. This is what you asked for?


Use ssh to connect to the device and then run the command.
Finally copy paste the output here using the "Preformatted text </>" button.

1 Like
Thanks a lot. I'm glad I now have it for you.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fdaa:53d5:b0b0::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'

Add string like:

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

See also:

404 Not Found

Sorry, the object you requested was not found.
Unable to dispatch: /cgi-bin/luci/admin/network/vlan

Sorry, but that's what I got after logging into the web-interface to that link you sent. Also, I don't now want to configure vlans, only want to the 'hard' ports working as switch ports normally do. Later, I will read and then configure vlans. Thanks so much for help.

Go to LuCI -> Network -> Switch, and make screenshot.

1 Like

thanks a lot. Here's the image below. You're kind and patient.

But can some please prime my next step to learn about vlan and tell me what we're looking at in this image here, please? Sources to learn about vlan, benefits, configuration, etc, will as well be great. Thanks all!

That looks right. If you plug another Ethernet device into a port (leave your PC on 4), does the icon change from no link to connected?

1 Like

I do feel stupid. I just plugged, one after the other, on all ports and ssh into the router, all worked. I don't know what has happened. I never changed anything. All I've done is run opkg update, which I used to test for another problem...see below. :grinning:
Thanks to everyone, everyone, really who read and helped. I can say now that all the ports work as a 'switch' after shh'ing into the router using them all, one after the other.
Perhaps you see my other question on Parental Control and could help...wink, wink. Thanks all.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.