Configuring PPTP client

Hi, I have a PPTP connection that I want to configure and I need help.
The connection options must be as the image below:
I've tried to edit /etc/ppp/options.pptp but it didn't work.
My options.pptp file now looks like this:

idle 0
mppe required
maxfail 0

All I get is Unknown error (NEGOTIOATION_FAILED) and Unknown error (OPTION_ERROR)
Please help

This doesn't match your picture - which you stated "must be as the image".

I removed these from the options and now the interface shows the error Unknown error (USER_REQUEST)

and in the system log, I get:

Connection terminated
Modem hangup

Any ideas guys?

Can someone please help?

It's not that helpful to show a Windows screenshot - can you provide your OpenWrt configs?

cat /etc/config/network

cat /etc/config/firewall

Also, have you seen:

Lastly, a quick web search shows many how-to videos for setting up PPPoE on OpenWrt.

In case you're not already aware, PPTP has been shown to be cryptographically insecure; it's considered "broken". If you have alternate choices for VPN protocols which offer better security, you would benefit from exploring them.

If you have no other choice apart from PPTP, then it'd be worth considering the security and reliability of whatever it is you're connecting to. Can you trust something whose operator still uses obsolete cryptographic protocols?

1 Like

My main problem is how to implement these windows settings into openwrt, so I don't have any openwrt configs and I've described what errors I'm getting along with the pptp options file

I don't understand how this can help me configure a pptp VPN connection on my openwrt router

You certainly do. Your screenshot shows a PPTP connection configured in LuCI. There will be corresponding entries in the files requested by @lleachii. And those entries might help to shed light on why it's not working for you.

1 Like

Apologies, I now realize I mistyped the web search on the device i made the post. Honestly I'm flabbergasted you're using PPTP VPN - as @iplaywithtoys noted, the protocol is insecure.

You have to have OpenWrt configs, as you get errors.


1 Like