Configuring LEDE with a PPPoE Modem/Router B-FOCus V-2FUb/r Rev B

Help please, I can not connect to the Internet VDSL2 Belgacom -> Belgium.
ADSL Router
B-FOCus V-2FUb/r Rev B
Firmware
lede-17.01.2-lantiq-xrx200-VG3503J-squashfs-sysupgrade.bin

/etc/config/network
root@LEDE:~# vi /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fda7:6128:a1d0::/48'

config atm-bridge 'atm'
option encaps 'llc'
option payload 'bridged'
option vci '35'
option vpi '8'

config dsl 'dsl'
option annex 'b'
option xfer_mode 'atm'
option line_mode 'vdsl'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.178.66'
option gateway '192.168.178.1'

config interface 'wan'
option ifname 'ptm0'
option proto 'pppoe'
option ipv6 'auto'
option username 'xxx'
option password 'xxx'

config device 'wan_dev'
option name 'ptm0'
option macaddr ':'

config interface 'wan6'
option ifname 'pppoe-wan'
option proto 'dhcpv6'

config switch

  • /etc/config/network 1/55 1%

Here this should work for Belegacom VDSL2
VLANid=10 Internt
VLANid=30 IPTV
Annex B xfer_mode B

Only needed for ADSL
VPI=1
VCI=32
xfer_mode ATM

For VDSL2

config dsl 'dsl'
option annex 'b'
option xfer_mode 'ptm'
option line_mode 'vdsl'

config interface 'wan'
option ifname 'ptm0.10'
option proto 'pppoe’
option ipv6 'auto’
option username 'xxx’
option password ‘xxx’

1 Like

Can I have incorrectly configured other settings?
There is no Internet connection with these changes. :cold_sweat::cold_sweat:
The modem is synchronized.

Thank you all, everything turned out. I spread my working config.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda7:6128:a1d0::/48'

config dsl 'dsl'
	option annex 'b'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.178.66'

config interface 'wan'
	option proto 'pppoe'
	option ipv6 'auto'
	option password 'xxx'
	option ifname 'ptm0.10'
	option username 'xxx'

config device 'wan_dev'
	option name 'ptm0'
	option macaddr ':'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 4 6t'
	option vid '1'

Help please adjust the work with the profile 17a

At the moment the modem is synchronized with profile 8b and in the annexes menu in LUCI there is no option g.993.2 but only g.992.x

I downloaded the file https://www.openreach.co.uk/orpg/home/products/super-fastfibreaccess/super-fastfibreaccess/landrgnu/downloads/code/ECI_Arcadyan_VDSL_modem.zip,

Using Arc, I unzipped the xcpe_hw.bin file from the dsl_vr9_firmware_xdsl-05.04.07.09.01.06_05.04.04.04.01.01 archive, renamed it to vdsl.bin, copied it to the /lib/firmware/

The following line is added to the /etc/config/network

option firmware '/lib/firmware/vdsl.bin'

The modem can not be synchronized

What am I doing wrong?

strange, now the synchronization is constantly breaking and recovering, but there was G.993.2 with a profile of 8a.

regardless of option firmware '/lib/firmware/vdsl.bin'

root@LEDE:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          Broadcom 177.174
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.4.7.9.1.6
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Profile:                                  8d
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 20
Severely Errored Seconds (SES):           Near: 0 / Far: 5
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 4
Unavailable Seconds (UAS):                Near: 198 / Far: 198
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 1 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Interleave (6.0 ms) / Up: Interleave (4.0 ms)
Data Rate:                                Down: 7.556 Mb/s / Up: 572 Kb/s
Line Attenuation (LATN):                  Down: 10.9dB / Up: 0.0dB
Signal Attenuation (SATN):                Down: 15.6dB / Up: 0.0dB
Noise Margin (SNR):                       Down: 14.2dB / Up: 36.3dB
Aggregate Transmit Power (ACTATP):        Down: 9.5dB / Up: 3.9dB
Max. Attainable Data Rate (ATTNDR):       Down: 15.727 Mb/s / Up: 2.820 Mb/s
Line Uptime Seconds:                      23
Line Uptime:                              23s

Thank you very much, everything turned out with the firmware
dsl_vr9_firmware_xdsl-05.07.09.05.01.07_05.07.03.0F.00.01

http://www.downloads.netgear.com/files/GPL/DM200-GPL_V1.0.0.36.tar.bz2

Extracting the source files:

tar -xf DM200-GPL_V1.0.0.36.tar.bz2 DM200-V1.0.0.36_gpl_src/dl/dsl_vr9_firmware_xdsl-05.07.09.05.01.07_05.07.03.0F.00.01.tar.gz
cd DM200-V1.0.0.36_gpl_src/dl/
tar -xf dsl_vr9_firmware_xdsl-05.07.09.05.01.07_05.07.03.0F.00.01.tar.gz

rename xcpe_579517_573F01.bin to vdsl.bin en copy to the router directory /lib/firmware/
The following line is added to the /etc/config/network

option firmware ‘/lib/firmware/vdsl.bin’

oot@LEDE:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:
ATU-C System Vendor ID:
Chipset: Lantiq-VRX200 Unknown
Firmware Version: 5.7.9.5.1.7
API Version: 4.17.18.6
XTSE Capabilities: 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex: B
Line Mode: G.993.5 (VDSL2 with down- and upstream vectoring)
Profile: 17a
Line State: UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS): Near: 0 / Far: 35804
Errored seconds (ES): Near: 0 / Far: 24
Severely Errored Seconds (SES): Near: 0 / Far: 5
Loss of Signal Seconds (LOSS): Near: 0 / Far: 4
Unavailable Seconds (UAS): Near: 127 / Far: 127
Header Error Code Errors (HEC): Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P): Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P): Near: 0 / Far: 0
Power Management Mode: L0 - Synchronized
Latency / Interleave Delay: Down: Fast (0.18 ms) / Up: Fast (0.0 ms)
Data Rate: Down: 50.064 Mb/s / Up: 15.064 Mb/s
Line Attenuation (LATN): Down: 18.3dB / Up: 21.5dB
Signal Attenuation (SATN): Down: 18.3dB / Up: 21.5dB
Noise Margin (SNR): Down: 13.0dB / Up: 6.5dB
Aggregate Transmit Power (ACTATP): Down: 1.1dB / Up: 13.6dB
Max. Attainable Data Rate (ATTNDR): Down: 94.251 Mb/s / Up: 22.063 Mb/s
Line Uptime Seconds: 9
Line Uptime: