Configuring LEDE router with a PPPoE Modem/Router

So, I have a Dlink dsl2730b provided by my ISP,which uses ppoe connection,and recently i got a Archer C7 v2,that i flashed LEDE into,but I'm having trouble trying to configure them both,I tried to put 2730b on bridge mode by disabling the DHCP and selecting Bridge on the WAN Service, but when i got to configure the router, I connected the Lan 1 from 2730b to the Wan port of the archer c7, and configured the eth1.1 as PPoE(wan,wan.6) and authenticate, while using the LAN (br-lan) plugged on my Computer (via lan),At first impressions, i thought it was working,but i could only acess some services,like Google,Youtube and Steam!And the SQM QoS seems to be broken too! Glad for answers.

Depending on your ISP you will be better off deleting the wan6 interface... For example for deutsche telekom lines which are dual stack the wan6 defaults are not great. The automatic wan_6 (note the underscore) however works great. Just give it a try and report back here?

It appears that you are trying to set 2 successive pppOe: ISP ---pppOe--> DSL2730b ---bridge--> to DSL2730B router ---pppOe--> Archer C7. Where do you supply the username/password authentication for your ISP?

In the States my set up is IPS ---pppOa--> Netis adsl in Netis) --static IP subnet--> Trendnet/LEDE static IP 192.168,2,1

I tried to authenticate on the wan/wan6 port on the router

Ill give it a try and report tomorrow!

I have no issues(except possible double NAT) on authenticating the pppoe on dlink2730b and plugging the archer c7,but its not what I'm looking for...

My goal is to let 2730b on bridge mode and do everything on archer c7,but its a confusion to authenticate it on LEDE,here are my Bridge Configs Screenshots below!
My true question is,how do I correctly authenticate it on LEDE?

Could you post the 2730b's configuration dialog when it is configured to terminate the PPPoE connection? Especially the Vlan8021p and VlanMuxId fields would be interesting...






By the way, the main reason for me to use LEDE is the SQM QoS, which seems to be useless with my actual config ( ISP-->PPPoE-->Dlink2730b-->Authenticate-->Dlink2730b Router-->Archer C7-->>Whole Internet(Comes from Wan, sends to br-lan)

With this config the SQM seems to have NO EFFECT, what makes me think it's a issue with the Dlink2730B,
You can see that in the ATM configuration, there's no option to disable the QoS using
Service Category: UBR without PCR , only this option has QoS, for example, UBR with PCR doesnt have it!

My guess is that if I manage to correctly authenticate the PPPoE on the Archer C7(Using Bridge Mode on Dlink2730b),
I can solve this issue

What is the IP / subnet of the Dlink dsl2730b vs. the Archer C7 v2 ?

On the Westell 7500 DSL modem here:

Private LAN IP:
Private LAN Subnet:

  • Important to set on a different IP vs. the LEDE router ..

DHCP: Disabled
Firewall: ( none )
Wireless: ( Disabled )

PCR: 100

  • Try:UBR without PCR on your DLink modem ..

Protocol: Bridge
Bridge Mode: Bridge

Patch cable plugged into (LAN) port on back of Westell 7500 modem / verified not a "Data, Uplink", etc. port -> to WAN (Internet) port of LEDE modem ..

LEDE Router ( Linksys EA8500 )

network -> Interfaces:


Protocol: PPoE
PAP/CHAP Username: ( supplied by Fairpoint / ISP )
PAP/CHAP Password: ( supplied by Fairpoint / ISP )

  • All other fields left at defaults / blank


Protocol: Static Address
IPV4 Address:
IPV4 Netmask:
IPV4 Gateway:

Use Custom DNS Servers:,

DHCP Server:
Start: 101
Limit 50

In short, setting a static ( local LAN ) address in the ISP provided DLink modem that is different vs. the LEDE router if setting to ( Bridged ) mode ..

  • How to access ISP modem, from LEDE router, if on a different sub-net: ( Thanks to @moeller0 )

LEDE Router:

Interfaces -> Interfaces Overview:

[ Add new Interface ]


Protocol: Static Address
IPV4 Address:
IPV4 Netmask:
IPV4 gateway: * Matches ISP Modem above ..

Physical Settings Tab:
Switch VLAN: "eth0.2" ( WAN, WAN6 )

You should now be able to "ping" and access the ISP Dlink Modem ..

Important: Add [WAN_4_MODEM] to the WAN Firewall zone:

Network -> Firewall:


Zones -> Forwards
[ WAN ] [ WAN6 ] [ Edit ]

General Settings: Covered Networks: Tick [ WAN_4_MODEM ] to add to Zone


Network -> SQM QoS

Enable this SQM instance: [Checked]
Interface Name: ppoe-wan

Hope this helps,

I Can only test new config's outside business hours,but i'll report as soon as possible!
The "LEDE Router:" of your instructions helped a lot.
But i think my SQM Problem is caused by the UBR Without PCR, is that a problem if I use UBR with PCR?If no,what should I fill "Peak Cell Rate" value with?
Glad!I'll try it tomorrow!!

Oh,my Ip configs are
Archer C7 v2
I'm able to acess both devices.

You can try ( 100 ) .. (* If the value is being used by the Westell 7500 modem here, it's working.)

I "think" this is what's causing your network "foo" / confusing IP access ( between the modem and router ), and possibly SQM .. I'm basing this on IP access issues I've seen, when the Modem -> and Router have had the -same IP Address and Gateway- in the past.

I would try changing the Modem to a different static IP address / gateway when setting in Bridge Mode ( like given above ), and test for positive effect, if possible.

With different mask's, I supose

You could try it - but I setup everything here partitioned with a Class C (/24) Netmask (small networks), so I can't provide better feedback on that, unfortunately.

I'll try setting up the Westell 7500 DSL modem w/ a Netmask of and test, give me a few minutes (I have a backup ADSL modem on stand-by, just in case).

Ok, I'm back - after resetting everything on the network. :slight_smile:

Using the class B worked in the Westell 7500 modem without issue, when the LEDE router was configured with a class C netmask,

  • Using the class B netmask in the LEDE router with a static IP of broke it.

DHCP was assigning addresses of 192.168.0. ... while the Gateway, DHCP, and DNS server addresses were --- it didn't work. Routing to WAN -> Internet access was also broken.

  • If you are going to use a static IP of in the LEDE router, use a class C netmask:

And don't forget to reset (all) network equipment: "endpoints" / workstations / servers, routers, hubs, switches, etc. in the LAN topology you have setup.. To avoid any IP Ghosts or Gremlins lurking about.

Kind Regards,

Awesome! Glad for your contribution!

Glad to help. Hope your LEDE install & config tomorrow goes well !