Configuring LEDE for IPoE (DHCP/automatic IP)

Can anyone help me set up my internet using LEDE on my wrt1900acsv2?
I have the wireless covered but cant get internet.
Usinf Aussie Braoadband that should be simple to set up buty it avoids me.
Needs IPoE (auto IP), VDSL2, auto DNS.
Help please before I go bald :frowning:

The default setting does that. It should be DHCP client on the WAN port. This will automatically obtain the IP address and DNS settings from the modem and/or ISP. On the Status Overview page you should see those settings under IPv4 or v6 WAN if it worked.

Did you you use this as a general guide

And this seems interesting:

Thanks MK24. Appreciate you responding to help me :slight_smile:
I was led to beleive that was the case but it doesnt seem to be doing that. Perhaps I'm doing something wrong. Is there something other than plugging it all in, starting it up and letting it do its thing that I need to know?
What Ihave done so far (a few times now) is:

  1. shut down everything (resetting to factory defaults on router, just shutting down the modem (which is bridged of course). Including shut down all pc's connected, then removing all ethernet cables (if wired connection).
  2. Connect cable from router yellow Ethernet port/connection to blue Lan port on modem.
  3. Connect ethernet cable from Lan port on router to PC.
  4. start modem. Allow time to boot up.
  5. Waitanother approx 30 - 60 minutes. Then boot up router, allowing time to completely boot up.
  6. Start PC and connect to router.

Is this the correct sequence? Anything missed out?
What should my next steps be to ensure it connects to internet as automatic IP and auto DNS?
Perhaps a better question is what screens to check and what should I see to confirm its setup correctly?

I'm sorry for being a pest and such a noob. I appreciate your help.

Thanks mbo2o. Yes, been there, done that :-). I know what the settings should be. I can set up in most other routers and modems etc working just great because they actually ask you to say type of connection etc..LEDE doesnt. My problem is making sure they are set in the LEDE configuration and how I can tell if they are, and what should I be seeing. Because it doesnt seem to be working as a default. Hence losing hair and respect of partner :frowning:

Hi Piquet

When using LUCI go to the Network->Interfaces page. This should show your the current status of your WAN interface.

Then select EDIT button for the WAN interface, I believe your protocol should be set to "DHCP Client", confirm you want to switch protocol if asked.

Save and Apply any changes

I take it your setup is:
PC=>LEDE Router=>ISP supplied VDSL2 Modem=>internet

mmm... Seems strange the wrt1900acsv2 WAN port is yellow, and Ethernet ports blue, I thought the standard was the opposite Blue WAN port, Yellow ethernet ports?

I just looked at my 3x routers and the colour coding is Blue WAN port/Yellow Ethernet ports.

So whatever colour coding, the Ethernet/WAN port on the LEDE router should be connected to a LAN port on the modem.

...then make sure you follow what mbo2o wrote above...

Page 7 , user guide WAN Port is Yellow

what model modem are you using, you may be using the wrong port here, It should be a LAN/ETH port (yellow usually)

Do not use the WAN port on the modem to connect your router/

I'm using the Huawei HG659 (an ISP supplied modem/router with VOIP) not bridged as I lose VOIP access, and have my LEDE router (TP-Link c2600 running 17.01.5) plugged into the HG659.

My setup is working fine, a different config to what piquet is trying to setup.

As mentioned, all my routers WAN ports are blue, and LAN ports yellow. I realized that the colour coding was different for the wrt1900acsv2 that's why I edited the post.

Thanks everyone. I finally figured it all out and I'm up and running. Now I have saved the config file for future use should something happen :-). Cant afford to lose more hair haha.
Thanks to you all for your help.
FYI: it was in the settings. Contrary to what I was led to believe it isnt set up by default for my use with AussieBB,. The auti IP and DCHP were fine but it was set for id tagging, which I had to first recognise what I was looking at and then how to stop. All good now.

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like