Configuring darkstat (package)

by default, darkstat monitors br-lan. where is the configuration where i can change which interface it monitors?

You probably mean darkstat...


Yes darkstat. Don't know how I came with that name :joy:

And thanks for the reply.

Hm, that is weird. When I open /etc/config/darkstat,
it says it listens on interface "lan" - when I try to change it to "br-lan", it fails to start. And it indeed seems to listen on br-lan, but why is just "lan" in the config file?

A couple a questions.

1)I would just like to monitor how much traffic originates from device on my local network. It seems the option "local_only" is designed for that, but when I enable it, al kinds of hosts are still listed.

  1. Also, I tried to make the stats persisent across reboots with the export/import/daylog options, but they do not seem t obe implemented in the init.d file as far as I can see. How can one still pass those options to the daemon? should it be filed as a bug/feature request. I am following this man page: (could not find much docs online)).

this is my config file:

config darkstat
        option interface        'lan'
#       option syslog           true
        option verbose          true
        option no_daemon        false
        option no_promisc       false
        option no_dns           false
        option no_macs          false
        option no_lastseen      false
#       option httpaddr         ''
#       option httpport         '667'
#       option network_filter   'not (src net 192.168.2 and dst net 192.168.2)'
        option network_netmask  ''
        option local_only       'true'
#       option hosts_max        '1000'
#       option hosts_keep       '500'
#       option ports_max        '60'
#       option ports_keep       '30'
#       option highest_port     '65534'
        option chroot           '/mnt/sda1/statistics_lede/darkstat'
        option daylog           '/mnt/sda1/statistics_lede/darkstat/daylog'
        option export           '/mnt/sda1/statistics_lede/darkstat/export_import'
        option import           '/mnt/sda1/statistics_lede/darkstat/export_import'

go for it

Hi, did you manage to pass the extra config option to the init.d file? I'm in the same boat.

No, I did not, sorry. Would be interested ot hear how to do that (and includign making the local_only option work).