Configure the WAN port for DNSClient

Hello all.

I have setup the OpenWRT so that it get DNS information from another router.

the Openwrt device used, has 4 LAN ports and 1 WAN.

when I Go to Interfaces, choose
Protocol: DNS Client
Device: eth0
It Fails for somereason

worked for Device: br-lan but had to move the ethernet cable from WAN to one of the 4 LAN ports.

is it suppose to be like that or I am mistaken with something else.

tried multiple configurations, Like choosing device internet and wan, but all not worked.

I guess if I coulnt do anything about it then forget about the WAN port.

the wire coming from Router1------->Lan[br-lan]
this only one that worked, so anyone connected to wifi of the OpenWRT get ip from router1 and connected to the internet...


Are you talking about DHCP or DNS? DHCP is the automatic address assignment, where DNS is completely different -- it is the Domain Name System (that converts to a numeric address).

What are you trying to do with your OpenWrt device -- what is its purpose on the network? What device is it (brand & model)? What version of OpenWrt is it running/


Sorry I didnt notice I made a mistake.
OpenWRT is the latset release, just installed

|Model|Linksys E4200 v2 (Viper)|
|Architecture|Feroceon 88FR131 rev 1 (v5l)|
|Target Platform|kirkwood/generic|
|Firmware Version|OpenWrt 22.03.0 r19685-512e76967f / LuCI openwrt-22.03 branch git-22.245.77528-487e58a|
|Kernel Version|5.10.138|

the router is acting as a lower priority kinda like extender, JUST as a WIFI. the ports in the device not used except for just connecting to the main router to have internet access. and most of the cameras in the apartment connected to it.

Since you're just suing this devices as a dumb AP, you'll follow the wiki article about it.

But you can post your configuration here and we can review what is going on.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall