Configure RP PPPoE Server

Hi
I have a Xiaomi AX3600 router as the main one connected to the operator's ONT (Digi Spain). I have installed openwrt. I want to use the IP phone but it only works with the operator's router ZXHN H298Q.
The ZXHN router does not have bridge mode and the operator does not provide SIP credentials.
With a Mikrotik router they have found a solution for the IP phone to work without the operator's router being the main one.

The Mikrotik (connected to the ONT) have deployed a pppoe server. They have connected the ZXHN to the Mikrtik and the IP phone has been connected to the ZXHN. The trick is that Mikrotik's pppoe server pretends to be the ONT and thus tricks the ZXHN.
I am trying to do the same with AX3600/openwrt + RP pppoe server but I have not succeeded. I ask for help.

The PPPoE configuration of the operator are:
VLAN ID = 20
user: xxxxxxxxxxxx@digi
password: yyyyyyyyy

I have assumed that the pppoe server must also have vlan=20.
To deploy the pppoe server. I have created a device called 'lan3.20'. Associated with device 'lan3' (physical port) with vlan 20.
The pppoe server requires an interface, so I have created an interface called 'lan3_pppoe_srv' associated with the device 'lan3.20' but I don't know how to configure it.

/etc/config/network

	config device
			option name 'br-lan'
			option type 'bridge'
			option igmp_snooping '1'
			list ports 'lan1'
			list ports 'lan2'
	# lan3 removed

	config interface 'lan'
			option device 'br-lan'
			option proto 'static'
			option ipaddr '192.168.1.1'
			option netmask '255.255.255.0'
			....
# ont/wan connection
	config device
			option type '8021q'
			option ifname 'wan'
			option vid '20'
			option name 'wan.20'

	config interface 'wan'
			option device 'wan.20'
			option proto 'pppoe'
			option username 'xxxxxxxxxxx@digi'
			option password 'yyyyyyyyy'

# device/interface for ppppoe server

	**config device**
**			option type '8021q'**
**			option ifname 'lan3'**
**			option vid '20'**
**			option name 'lan3.20'**

**	config interface 'lan3_pppoe_srv'  ¿?¿?**
**			option device 'lan3.20'**
**			option proto ?????**
**			?????**

/etc/config/ppp/pppoe

	config pppoe_server
			option ac_name 'access-concentrator-name'
			list service_name 'service-name'
			option maxsessionsperpeer '1'
			option localip '192.168.2.1'
			option firstremoteip '192.168.2.2'
			option maxsessions '64'
			option optionsfile '/etc/ppp/pppoe-server-options'
			option randomsessions '1'
			option unit '0'
			option offset '0'
			option timeout '60'
			option mss '1468'
			option sync '0'
			**option interface 'lan3_pppoe_srv'**

/etc/ppp/pppoe-server-options

	require-pap
	#required-chap   # I try with pap & chap
	login
	lcp-echo-interval 10
	lcp-echo-failure 2
	mru 1492
	mtu 1492

/etc/ppp/chap-secrets

	#USERNAME  PROVIDER  PASSWORD  IPADDRESS
	xxxxxxxxxxx@digi  *       yyyyyyyyy        *

/etc/ppp/pap-secrets

	# client        server          secret          IP addresses
	xxxxxxxxxxx@digi  *       yyyyyyyyy        *

Thanks

1 Like

I connected two router by ppppe with this config:

config device
        option type '8021q'
        option ifname 'lan3'
        option vid '20'
        option name '**lan3.20**'

config interface 'srvPPPoE'
        option proto 'static'
        option device '**lan3.20**'
        list dns '1.1.1.1'
        list dns '1.0.0.1'
        list ipaddr '192.168.2.1'

The Digi router status:
TYPE: PPPoE
Nat: Active
IP: 192.168.2.2/255.255.255.255
StatusIPv4: Connected
Dns: 0.0.0.0/0.0.0.0/0.0.0.0

But I don't have internet access and DNS (doesn't get 1.1.1.1 / 1.0.0.1).

I tray to set gateway: 192.168.1.1 or 10.0.0.1 but it doesn't work.
Any idea?

I have tried a multitude of changes to both the device, interface and PPPoE server and can't find anything that works.
The question remains the same: How to connect the client (secondary router/Digi) of the PPPoE server to the WAN of the main router/Xiaomi?

I solved it. In case anyone is interested.