Configure router as repeater on the same radio

I'm trying to use a tp link router as a repeater on the same 5ghz radio.
When I add a client, the AP just stops working(doesn't even show on my phone's wifi). It works only when the AP is on a different radio.
the client is on 192.168.1.1 and i want to set the tp link on 192.168.2.1.

First of all, please keep in mind that your AP will only work (be visible) when your client router is on and WiFi can be connected to. Have you tried to consult the documentation on openwrt.org?

Can you provide your config files? Output of cat /etc/config/wireless and cat /etc/config/network?

1 Like

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd16:e8ff:56e8::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option ifname 'eth1 eth1.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 5 4 3'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 2 1'
        option vid '2'

config interface 'wwan'
        option proto 'dhcp'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-iface 'wifinet1'
        option ssid 'Vodafone-34688240'
        option device 'radio0'
        option mode 'sta'
        option key 'edtdhz38bp6ucp9'
        option encryption 'psk2'
        option network 'wwan'

config wifi-iface 'wifinet2'
        option encryption 'none'
        option device 'radio0'
        option mode 'ap'
        option hidden '1'
        option network 'lan'
        option ssid 'test'

Your config seems okay to me and it should be working if you are able to connect to "test" WiFi considering it has been marked as hidden AP. If you are not able to see "test" WiFi then please remove option hidden '1' from the config and then execute wifi to make it appear.

1 Like

still doesn't work.
Current power: 0 dBm

Always put your country in the wifi config, if you leave it unset you only get the lowest common permissions which are legal in all countries which may not be enough.

Find out what channel the AP you are connecting to is using, you often need to set that same channel in your config to be able to start up an AP while the client is on.

Also depending on the hardware / driver and whether it is a DFS channel or not, this may not be possible.