Configure pppoe to no avail

I'm trying to configure PPPoE on my D-Link DIR-878 (A1) router, but I'm not getting it, I tried several times. You could help me, tell me what I'm doing wrong.

Thank you

Build I'm trying to

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd2e:0c66:415a::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'pppoe'
        option username '@vbeixxxxxx'
        option password '1234'
        option ipv6 'auto'
        option keepalive '0'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

What ISP and what access technology (ADSL, cable, fiber), And what is the output of logread | gre ppp (make sure to redact contain sensitive information like usernames and passwords before posting here).
I would guess just a "Timeout waiting for PADO packets" as that is the generic error one sees when PPPOE client and server can not establish communications fr whatever reason, including cable disconnected...

1 Like

Change that to '6 10'

This will spawn a wan_6 interface to negotiate the dhcpv6. However you have already a wan6 interface for that. Either switch this option to '1' or delete wan6.

Since MT7621 switched to DSA, eth0 is a DSA master port so you cannot use it directly.
Change wan's ifname to wan, and remove wan6.


Some ISPs have special requirements (mostly VLANs). If you can see the configuration from a device that can connect, that would help.

I tried several settings. PPPoE connects, passes packets, but does not connect to the internet
I have 100Mb cable

Mmmh, DOCSIS cable standards recommend/mandate DHCP for provisioning, this is the first time I hear about PPPoE being used over cable...
Which ISP is this, and what do they give as information to configure one's own router?

My provider is optical fiber, up to the pole. They are in the process of expanding for fiber to enter the customer's home. I use a local ITS Telecom ISP.

Yes, they give everyone the default login and password

Use use DD-WRT has about 8 months in this router, and it always works well, but in OpenWRT I am not getting it

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*