Configure interfaces on OpenWrt 22.03.0-rc6

Much again has changed, even from 21.0. Can someone please help me configure a LAN port on this DSL/Modem router to use as WAN please on OpenWrt 22.03.0-rc6?

I went as far as "interfaces" but could not figure out how to go further. Thanks a lot!

You are looking for DSA based configuration approaches. Forum and wiki have quite a few examples which should get you going,

1 Like

@slh thanks a lot. I've been looking but it looks like for DSL modems it's different. I've reset the router now 7 times, because none of the ones I've seen work. I'm on a Fritzbox modem.

What device is this?

Pick your LAN port. For example, lan1. Click 'configure' for the 'br-lan' device, and remove the selected LAN port from the bridge (i.e. from the menu 'bridge ports').

Then create a new interface (call it wan), and choose the LAN port you removed from the bridge as the device for the interface. Create the firewall zone wan to cover the new interface, and it should act as as wan port.


@kramsac thanks, John, it's a Fritzbox 7360. I will give this a try.

Let us know if it works!

@kramsac John, it worked. And I'm now going to list my steps here for anyone looking. Please verify and perhaps it could be added to the Wiki, since this DSA configuration is an issue for many.

Connect your computer to hardware Ethernet Port 2 on your router.  If you connect to LAN 1 and try to remove that port later, you will be LOCKED OUT. Just FYI. 
Login to Luci and then go to Interfaces > Devices
Click on Configure on br-lan
On the Bridge Ports, click and deselect LAN 1 or a port of your choice. You will be 'removing' a hardware port via software. DO NOT remove the port you are presently connected to.
Go to Interfaces and at the bottom click “And New Interface”
Give it a name as you wish. I have mine; onehumanrace
On Protocol I left mine as DHCP. Perhaps someone can say if this is right or wrong, benefits or not.
On Device select "lan1" or whatever lan port you had removed earlier from br-lan. This is important.
Click Create Interface
Go to Firewall Settings and click on the interface you created and named earlier. And click Save.
The click Save and Apply.
You’re done.  

Glad it worked!

Make sure you choose 'Ignore interface' in the DHCP server tab of the interface. Otherwise seems good to me!

@kramsac thanks a lot. that seems to have been automagically selected. while i have your attention, are you aware of any issues configuring wifi on rc6? the LED on the router is on, but the radio button on LUCI is grayed. Thanks a lot.

@kramsac never mind, apparently only some of the security options work. Others simply don't.

Sorry, don't know anything about your device .

im successfull to creat a vlan tag..but after that.may wan have no internet.

I have the same issue with using vlan on WAN port.
Connection is up but WAN is not accessible from the LAN.

@kramsac can you please help me finish this. So, I can do opkg update via ssh and luci, no problem. The Ethernet connected to physical LAN port 2 and on my laptop will not get me to the Internet using Firefox, a rather strange problem. Any ideas, please?

Have you enabled masquerading on the WAN, and set up a firewall rule to allow Lan to wan?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.