Configure Fritzbox 7530 as a router only

:wave: everyone!

I'm having trouble configuring my Fritzbox 7530 as a router only behind my ISP modem, I configured the modem in bridge mode on VLAN 158 as required by my ISP. But I'm confused how to configure OpenWrt, so far I think that I can't use the DSL port but instead use one of the LAN ports as the new WAN right?
Another complication is that my ISP is expecting a specific mac address (the modem's) and now I'm not sure if that configuration should also be on the OpenWrt router or not?

This is my current config for the Fritzbox 7530 that runs as modem+router.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdaa:9599:affc::/48'

config dsl 'dsl'
        option annex 'j'
        option ds_snr_offset '0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'dsl0'
        option macaddr '<MAC>'

config device
        option name 'dsl0.158'
        option ifname 'dsl0'
        option type '8021q'
        option vid '158'

config interface 'wan'
        option device 'dsl0.158'
        option proto 'pppoe'
        option username '<USERNAME>'
        option pppd_options 'debug'
        option password '<PASSWORD>'
        option ipv6 '0'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'

config interface 'tailscale'
        option proto 'none'
        option device 'tailscale0'

A minor detail is that I'm trying a bridged configuration because the dsl line has micro cuts I think and for some reason the Fritzbox cannot reconnect successfully without a reboot (or removing the vrx518 kernel module and modprobing it again which is annoying and crashes the router sometimes)
It's somewhat similar to this issue but it's a different router: BT HomeHub 5A not reconnecting when re-plugging DSL cable - #19 by takimata
The last kernel log I find after the DSL is down and it can't reconnect is:

[46448.439233] vrx518_tc:ptm_showtime_exit: Line[0]: show time exit!

Remove one lan from the bridge device, e.g lan1

Define the desired mac for lan1.

New device is lan1.158
The rest should be the same.

Yep.

I think there is a patch pending to resolve some modem stuff...?

@trendy provided the correct way to connect LAN1 as 'WAN' for connection to ISP provided Ethernet.

This looks like a different issue, because it sounds like the connection works fine at least initially in this case. On a device which needs that hack it wouldn't work at all (on affected devices, the DSL link can be established, but no data is transmitted over it).

@janh You are right, that patch is for different 7530 versions that always fail to connect with vrx518 0000:01:00.0: dc_ep_clk_on failed. The connection on my 7530 works fine until it cuts off for a few seconds and it has to reinitialize.

I tried the following config and it didn't work, so at this point I'm pretty sure it's the a modem problem and not OpenWrt's. The modem's UI is extremely simplistic so I don't really have much options to try (I wish it was OpenWrt compatible):

Although I did try all different 4 LAN ports (one of them is a LAN/WAN port so I guess I shouldn't be using that one)

Mon Jun 17 17:15:17 2024 daemon.info pppd[20640]: Plugin pppoe.so loaded.
Mon Jun 17 17:15:17 2024 daemon.info pppd[20640]: PPPoE plugin from pppd 2.4.9
Mon Jun 17 17:15:17 2024 daemon.notice pppd[20640]: pppd 2.4.9 started by root, uid 0
Mon Jun 17 17:15:17 2024 daemon.debug pppd[20640]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Mon Jun 17 17:15:17 2024 daemon.debug pppd[20640]:  dst ff:ff:ff:ff:ff:ff  src a0:a3:f0:0e:5d:6e
Mon Jun 17 17:15:17 2024 daemon.debug pppd[20640]:  [service-name] [host-uniq  a0 50 00 00]
Mon Jun 17 17:15:22 2024 daemon.debug pppd[20640]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Mon Jun 17 17:15:22 2024 daemon.debug pppd[20640]:  dst ff:ff:ff:ff:ff:ff  src a0:a3:f0:0e:5d:6e
Mon Jun 17 17:15:22 2024 daemon.debug pppd[20640]:  [service-name] [host-uniq  a0 50 00 00]
Mon Jun 17 17:15:27 2024 daemon.debug pppd[20640]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12
Mon Jun 17 17:15:27 2024 daemon.debug pppd[20640]:  dst ff:ff:ff:ff:ff:ff  src a0:a3:f0:0e:5d:6e
Mon Jun 17 17:15:27 2024 daemon.debug pppd[20640]:  [service-name] [host-uniq  a0 50 00 00]
Mon Jun 17 17:15:32 2024 daemon.warn pppd[20640]: Timeout waiting for PADO packets
Mon Jun 17 17:15:33 2024 daemon.err pppd[20640]: Unable to complete PPPoE Discovery
Mon Jun 17 17:15:33 2024 daemon.info pppd[20640]: Exit.

What does your configuration in OpenWrt look like now?

If the external modem already does VLAN tagging, you don't need to configure it on the router anymore.

I tried a different modem today and it worked. I also removed the VLAN tagging from the OpenWrt configuration, thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.