Configuration 3G LTE modem

I am do all of these steps correctly, but still there is problem to connect to my sim card, what could be the problem ?


inst2

.
.
.
.
Result:
inst3

APN looks wrong to me. What does their website/tech support say?

Edit: First hit on Google tells me it probably is: internet

Login using ssh and check the system log for problems starting the 3G_4G network:

logread -l 35 | grep 3G_4G

If you aren't interested in IPv6 you could try changing the PDP Type to IPv4.

One thing to consider - is your modem actually in QMI mode?

Modems don't automatically switch modes just because you are using a certain protocol.

If your modem is using MBIM then it just isn't going to work.

Looking at the System Log may show you what mode it is using.

1 Like

If the SIM is not detected, one thing to check is whether your modem supports dual SIM. You may need to change the active SIM slot via QMI; I think the qmicli command should be --uim-switch-slot=[1|2]

Also, you could try modemmanager instead

This is the result my bro ! :neutral_face:

Sorry brother I am not professional in this, Can you help me step by step, what should I run.

It looks like the modem isn't in qmi mode as suggested may be the case by @Dairyman.

Need to find out which modem you have to be able to reconfigure it for qmi:

cat /sys/kernel/debug/usb/devices

This is the result brother, What should I change ?
1
2
3

I suggest you go to the ltehacks forum and ask for help there and use the rooter firmware (openwrt but with sim config and easier to use)

https://wirelessjoint.com/viewforum.php?f=58

Also, developer section is not to be used for general questions.

It shows it's using the qmi_wwan driver but for manufacturer and product it just says Android which isn't much help.

Did you try 'internet' as the APN as suggested by @Bartvz?

To make progress it may be helpful if you could list what you know about your setup. For example the manufacturer and model of the router and the firmware installed. The manufacturer and make of the modem etc.

How would you describe mobile broadband functionality on stable releases of stock OpenWrt to rightfully justify it as unsupported on the forums?

I found qmi is workable for at least 21.02.1 but mbim is broken. Often it's down to hacking a working setup which requires some expertise.

My router: tp-link mr6400 V5 and I installed the firmware from the main website of openwrt.

Someone on here has the same router and solved the problem:

You could use an editor to manually edit qmi.sh on your device to add the timeout parameter.

The second part of the solution is to disable dhcp on the 3G_4G interface (but your setup may not require this):

uci set network.3G_4G.dhcp='0'

Hi
You can try my modified version of uqmi: https://github.com/mrhaav/openwrt

wget https://github.com/mrhaav/openwrt/raw/master/21.02.1/uqmi_2021-12-22-0.4_mipsel_24kc.ipk
opkg install uqmi_2021-12-22-0.4_mipsel_24kc.ipk

But, I agree with @Bartvz and @ai8, try with APN = 'internet'

1 Like

This is the solution, I install the modified version then I connected to my sim card.

Thanks brothers :heart_eyes:

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.