Config mwan3 to loadbalance between 2 wan connections


What I can have bad configured? My router it’s a TP-LINK WR940N V4. It isn’t loadbalance properly, when I go to a whatsmyip page that shows always the wan1 IP, it NEVER uses the wan2, and in details everything is okey I guess, in balanced policy wan have 60% and wan2 40%, but wan2 it’s never used by the router, just when wan goes down.

I need some help, thanks.

up :pray::pray::pray:

I don't use this package or anything, but I'm going to mention something that looks strange compared to what you want....

Under MWAN policies, your top policy is "wan_only" which only uses wan_m1_w3 so... that seems like what will happen. Only if wan is not available would you then fall back to wan2_only policy.... and since when that's not available neither are the others... that's all you'll get right?

I think what you want is "balanced" and then "wan_only" and then "wan2_only"??

Thanks for your reply bro, I get it.

I try this way and nothing: Captura%20de%20pantalla%20(238)

I also try to change members order, the result is the same. I already did a lot of test's: changing metric values, rules to use wan2 only, using more weight on wan2 (balanced policy), changing the policies order multiple times, etc... But the wan2 is just being ignored on my network, the only way to use it is disconnecting wan1 cable, then the router start using wan2 very faster.

I don't know what to do, I just want to use my 2 wan 50-50.

I think you'll need someone familiar with the specifics of this package. Not me, unfortunately.

You might search the forum for other threads on MWAN...

Rather a guess here since your config seems to differ a bit from the default I know. Your rule DVR4 is for port 443 and redirects to HTTPS. In the default setup there is a rule for port 443 called sticky which causes HTTPS connections to keep using the same route due to how HTTPS is intended to work properly. Try instead or some other site (you can find suggestions on StackExchange).

I use this package, I know a few things and this is what it looks to me (defaulting to HTTPS can lead to such issues), I'm not a network expert though.


1 Like

I factory defaults my router, using the default mwan3 configuration the result is the same. My DVR rules are for a security system, that rules of using wan1 are determined to a single local IP address. But with default settings that’s the same result. image

I will research on another forums, thanks to everybody for the help, I appreciate it a lot.

your "default_rule" only applies to destination addresses on your lan... that seems wrong. Doesn't seem like you have any rule at all describing what to use when accessing destinations outside your lan, so perhaps then it just goes to whatever the default is in the regular routing table?

I already using instead of a lan IP. image

But wan2 still unused, I try without https sticky rule too. (Without that rule all my traffic should be balanced, but it doesn’t.

how are you testing the nature of your traffic?

The only way that I know that is consulting my gadgets public IP address via multiple ways, it is always wan1. According to that should be using both 50%-50% : image

Troubleshooting page show that all my wan traffic is going though balanced policy, so I really don’t know what’s happening, I have everything configured same as the guides and videos.

Did you solve your problem?

check this notes, me and some users used it and had no problems with it:

hi here
try to put the defaut rule up .
and sticky_https is not applying the policy "balanced" but "wan_wan2"- should it the changed?
i made it work

  • policy wan_wan2 should be put at the top of policies in the " MWAN - Policies" window of Luci - network- loadbalancing - policies
    with both change it load balance the traffic in my conf
    best niouflex

I faced the same problem, status page says traffic is load balanced but only wan1 actually used. I manged to get it working by deleting the load balancing rule and add it again.

I guess if you edit members or policies after the load balancing rule is already added, changes won't take effects, you have to add rule again if you make changes to members or policies

ever experienced odd things with mwan3
readd the rules is the solution :+1: