CONFIG_ALL doesn't mark packages as {m}

I've set and verified CONFIG_ALL in .config, but when I build out, the system only builds the Baked-in Packages that I've set. I've done make clean, make menuconfig,make defconfig, etc. I've touched all the Makefile and *.mk to refresh (just in case). The flags are there, but they don't seem to be picked up by the build system. What did I miss?

Screenshot from 2020-07-03 20-48-00

#
# Global build settings
#
# CONFIG_JSON_OVERVIEW_IMAGE_INFO is not set
CONFIG_ALL_NONSHARED=y
CONFIG_ALL_KMODS=y
CONFIG_ALL=y
# CONFIG_BUILDBOT is not set
CONFIG_SIGNED_PACKAGES=y
CONFIG_SIGNATURE_CHECK=y

I had to remove all the is not set lines. CONFIG_ALL doesn't over-ride an is not set in the file, it will simply set ones that are missing to {m}.

sed -i '/is not set/d' .config solved the issue.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.