Compile Openwrt on Debian 9 error


#1

Hi, I'm trying to compile openwrt x86 and get this error.

make[3]: Entering directory '/app/openwrt/tools/m4'
CFLAGS="-O2 -I/app/openwrt/staging_dir/host/include " CPPFLAGS="-I/app/openwrt/staging_dir/host/include " CXXFLAGS="" LDFLAGS="-L/app/openwrt/staging_dir/host/lib " make  -C /app/openwrt/build_dir/host/m4-1.4.18  
make[4]: Entering directory '/app/openwrt/build_dir/host/m4-1.4.18'
CDPATH="${ZSH_VERSION+.}:" && cd . && /usr/bin/env bash /app/openwrt/build_dir/host/m4-1.4.18/build-aux/missing aclocal-1.15 -I m4
autom4te: need GNU m4 1.4 or later: /app/openwrt/staging_dir/host/bin/m4
aclocal-1.15: error: echo failed with exit status: 1
Makefile:1562: recipe for target 'aclocal.m4' failed
make[4]: *** [aclocal.m4] Error 1

I have installed automake but I still get the same error.
Maybe I need to install something else?
Thank you.


#2

Have you installed everything listed here? https://openwrt.org/docs/guide-developer/quickstart-build-images


#3

Yes I do.
Copy and paste in debian console. This process is right.


#4

Execute "m4 --version" and check if version 1.4 is installed.


#5

Gracias Eduardo. Un saludo desde Canarias.
I think I've found out the error. The git repository was generating it in a folder mounted to an sftp site. I think that by this way the links did not work giving rise to this compilation error.
Thank you.


closed #6

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.