Compile error: pkg_install_cmd: Cannot install package

I added a target for our company, and selected the LuCI option, but it always give an compile error just like below. Can someone give me a help? How to slove the preblem like Cannot install package ?

Collected errors:
 * check_data_file_clashes: Package libustream-wolfssl20201210 wants to install file /home/openwrt/build_dir/target-aarch64_cortex-a53_musl/root-ict8800/lib/
        But that file is already provided by package  * libustream-mbedtls20201210
 * opkg_install_cmd: Cannot install package libustream-wolfssl20201210.
 * resolve_conffiles: Existing conffile /home/openwrt/build_dir/target-aarch64_cortex-a53_musl/root-ict8800/etc/ppp/options is different from the conffile in the new package. The new conffile will be placed at /home/openwrt/build_dir/target-aarch64_cortex-a53_musl/root-ict8800/etc/ppp/options-opkg.
make[2]: *** [package/Makefile:70: package/install] Error 255
make[2]: Leaving directory '/home/openwrt'
make[1]: *** [package/Makefile:111: /home/openwrt/staging_dir/target-aarch64_cortex-a53_musl/stamp/.package_install] Error 2
make[1]: Leaving directory '/home/openwrt'
make: *** [/home/openwrt/include/ world] Error 2

It seems that some of the packages you selected are using mbedtls crypto library, while others are using wolfssl. The solution is to choose only one of these two libraries. Most packages that need crypto can be set to use another library with an option in menuconfig.

  • Find wolfssl and mbedtls in menuconfig, open the detailed info page and write down which packages selects them (see "Selected by Y" line).
  • Go to each of those packages and see if there are any options to change their crypto library.
  • When all your packages are set to use the same crypto library, go to the other one (now unused) and un-select it.
  • Run a make clean, before trying to build again.
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.