[CLOSED] Vs 22.03 keeps missing the gateway

BTW - this is why it was advised to install/use the LuCI web GUI (i.e. so you don't have to guess syntax).

Your decision not to use LuCI implies you know/understand correct OpenWrt syntax, but then you subsequently note here that you do not.

That's somewhat confusing.

1 Like

I'm sorry, I am overwhelmed with things in life while trying to understand this at the same time. I'll review again and try to provide the things I didn't provide.

I do not use the gui so there is no point in installing it. I'd like to better understand what I'm doing from the command line. There's nothing confusing. I said I'm not familiar with the wording (I called it syntax) of the network and wireless files since I've never had to touch those.

There aren't any specific urls to share, it's just stuff I found over the Internet and in the forums that I was trying to learn from, obviously all wrong for this version of openwrt. That's the problem with so much information on the net and not doing something like this on a regular basis.

This is the original file I got from the downloaded build off of the openwrt site.


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd17:78ff:5e34::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

And this one is the one I'm running right now.


config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'eth0.1'
    list ports 'eth0.2'

config interface 'lan'
    option device 'br-lan'
    option proto 'dhcp'
    option ip6assign '60'
    option ifname 'br-lan wlan0'

config interface 'wan'
    option device 'eth0.2'
    option proto 'dhcp'
    option metric '10'
    option ifname 'wlan0'

config interface 'wwan'
    option device 'radio0'
    option proto 'none'
    option metric '30'

config interface 'wlan'
    option device 'radio0'
    option proto 'none'
    option metric '40'

Why do you have metrics?

I used metrics because I wanted the wireless to become the default route/gateway if I activated it.

Why is eth0.2 incorrectly configured for both LAN and WAN?

Lack of knowledge in this which is why I posted.
As mentioned, what I shared are where I left off, one of many tries to get this right.

That cannot be the case, unless you're not using official OpenWrt firmware.

As I mentioned before, I was testing and lost track of things and since this configuration is not something I know much about, ended up with a mess. Comparing the two, I can see some differences of course.

I'm not sure what to do about this since I got it from another device. I'm not sure this is something you can copy from one device to another.

config globals 'globals'
        option ula_prefix 'fd17:78ff:5e34::/48'

Why is radio0 incorrectly assigned to 2 interfaces?
What is wlan?

Again, just stuff I found while searching, things I was trying.

This is the original wireless file.


config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

This post keeps getting longer and longer and I'm not sure what I've missed at this point that I should have provided. Maybe I need to find someone like a freelancer to help me since I obviously have gotten confused over time from all the mistakes I made. I would like to delete this question as useless to anyone that finds it.

Cool, if you insist.

What about the original file in your router by default?

I would have adviseed you start from there.

Yes you can. If you're not clear why, there's a Wikipedia entry on ULA.

BTW, you answered but your responses didn't make clear if you intended to fix it.

Ummmm, OK. Without details it's hard to suggest/know - but that makes sense. :+1:

Sure. Just mark your post as solved and it will close in 10 days.

I don't understand the passive aggressive manner but I give up. I guess I'll have to keep searching the Internet until I can understand and figure this out.

I apologize, I wasn't attempting to be.

I was just suggesting to use the default files (since you said the files came form elsewhere and not the default files), and telling you how to close the topic. I'm not even exactly sure which statement you took as passive aggressive, but there was no intention.

Lastly, I again suggest you to use the WIki - and I wish you the best.

I'll just mark the topic - so it'll close, in the future, it's common we ask users do this themselves (See How to mark a topic as [Solved] for a short how-to). Perhaps that's what you took as passive aggressive - again apologies.

1 Like

I suppose I could be wrong but as the person that is struggling to get this working, it just feels like you're being very nice and at the same time, constantly telling me what I'm doing wrong as I'm actually trying to be responsive. However, I seem to be missing questions and other points here and there which would frustrate someone helping.

It seems this post will go on and on and I just have to figure this out on my own, without asking for help or hire someone that will help me. You keep asking me to clarify what I'm up to which I did early on or in the first thread. I don't know, I've lost track at this point.

The main clue you've given me is that my files were wrong. The network file had interfaces in the wrong place etc and had wireless interfaces which should be in the wireless file.

I've updated the two files and think I'm on the right track now so thank you for that.

I think you've let your frustrations get to you - as hiring someone seems completely unnecessary to me. You have a solution available.

I know you don't wish to use the GUI and would like to use command line - but honestly you could simply:

  • install web GUI
  • configure
  • immediately uninstall web GUI
  • then review the configs via command like previously

Therefore:

  • you'd be 100% guaranteed to have a valid config files with correct syntax; and
  • you'll still learn and be able to use command line

It's cheaper than hiring someone - and you may be upset the person you hired simply installed the web GUI as we suggested to configure your router (I know I would be). But that's you're preference and your choice to pursue - personally it just seems unnecessary to insist you're struggling with these config files, when there's a clear solution to help you. As a bonus - when pursuing that option, you don't even have to risk further miscommunication with a human (or maybe I'm an AI, just kidding - lol).

Personally, I use the command line too - but for providing examples here, testing and verifying I made the correct config, I still use the web GUI.

This is why I said "if you insist" - I realize now that you may have been confused or made upset by this response. At the risk of this post not being welcomed, I digress and apologize in advance.

Again, I hope that you have the best of luck with your config.

I've not been made upset. I've simply not been able to follow this now very long thread.

I'll install luci on one of my routers an d see what I can learn from that.

It's not luck I needed, it was help to know if I get it right once I get there :).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.