Clients connected to OpenWrt router are unable to "see" the gateway

I have a (main) modem/router 192.168.0.1/24 to which I have connected an (wired) openwrt 18.06.4 device (nexx wt3020) 192.168.0.3. The screenshot below shows lan settings on openwrt. The main router is set as the lan gateway.


If I connect a client to the openwrt device, I am able to ping the device address and also to browse the web, but I'm unable to ping any client connected to the main router as well as the main router. Similarly, from a client connected to the main router, I'm unable to ping the openwrt device and any client connected to it. So, it is as if I have two different separate networks, even if the lan is only one!
What's wrong?
Here below I report the /etc/config/network content (even if I prefer to work with the GUI since I fear to do some mistake, as it has already happened in the past, and it has been a blood pain).
Thank you for your comments.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd10:00c4:d5cc::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ip6assign '60'
        option gateway '192.168.0.1'
        option ipaddr '192.168.0.3'
        option netmask '255.255.255.0'
        option dns '1.1.1.1 1.0.0.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '20:28:18:a1:13:d2'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option type 'bridge'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '20:28:18:a1:13:d3'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

config interface 'TetheringWAN'
        option proto 'dhcp'
        option ifname 'usb0'

Post Scriptum: I have also tried to disable dhcp on the openwrt router (since it is already active on the main router), but nothing changes.

https://openwrt.org/docs/guide-user/network/wifi/dumbap

3 Likes

I've already followed that guide word-by-word (by the way, it contains a mistake, steps 6 and 7 should be swapped), without no success.

Asking probably the obvious, you connected the modem to a LAN port of the OpenWrt router and you are sure that 192.168.0.3 isn't already attributed to another device on the modem?

I don't quite understand... Step 6 advise to disable stuff and step 7 states to save and reboot. Why should they be swapped? You mean save before disable then reboot?

2 Likes

Likely the issue is at the main router side. Does it have some isolation mode enabled where lan clients are not allowed to see each other? Try replace the openwrt device with an ordinary client and see if it can communicate with other clients

Obviously, yes.

"Click the Save and Apply" button. has to be applied to step 5. "System → Startup" has no "Click the Save and Apply" button; changes are applied instantly.

In the end I succeeded in making it working.
I did two changes, I don't know if the first one is important but the second one surely yes.
First: on openwrt GUI, I bridged eth0, eth0.1, eth0.2 interfaces.
Second: on the (windows) clients connected to openwrt router, I set automatic dns in the TCP/IPv4 properties. Before fields were filled with some specific dns (1.1.1.1) that evidently prevent the clients to recognize (and be recognized for) the right IPs.
After that changes, everything went smoothly.
Thanks for your patience.

Glad that it finally works. Were you trying to ping by hostname instead of specifying IP address directly?

I always ping by IP.
I don't know exacly what was the source of the problem.
But I know that in the TCP/IP properties I had "obtain IP automatically" and two custom DNS servers and the client didn't connect to the gateway.
When I changed TCP/IP properties to "use this IP/mask/gateway" and "obtain IP automatically", the problem disappeared. Then I made some other changes to TCP/IP properties, but the problem didn't raise anymore.

Most likely you triggered DHCP release and renew as DNS settings do not affect IP connectivity.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.