CIFS not working on latest release

Hi everyone!

Need some help here ... I'm getting the following when trying to mount a CIFS partition as I did in the past:

root@RouterACS:~# mount.cifs // /mnt/NAS -o unc=\\\\\\4T,ip=,user=mariano,pass="password",dom=workgroup

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I have the latest version of cifsmount , luci-app-samba and kmod-fs-cifs installed... maybe I'm missing something?

You might read this

Yeap.... Nothing new there ... the exact same command that I've pasted
above worked before, and is just not working now :frowning:

What is "latest release" for you? Snapshot or 17.01.2?
Please always be specific in this regards, because with the next release, your "latest" release will not be latest any more.

Are you sure that kmod-fs-cifs is installed, and that it is installed correctly (i.e. no errors during install)?

I'm on David's build "Lede Reboot SNAPSHOT r4323-1898f73 / LuCI Master
(git-17.171.49248-cb557f6)" .

kmod-fs-cifs installed with no errors, yes.

You gave me direction to investigate more and I fixed the issue now... I
was using kmod-fs-cifs v 4.9.20-1 and there was a new v 4.9.30-1 , that
also installed the kmod-rypto-*

That solved the issue!

1 Like