Changing wifi region issues

I use custom OPENWRT LEDE v17.01.2 firmware with Linux 4.9.44 kernel version. I also use mac80211 and cfg80211 kernel modules in kernel configuration to support wifi cards. I can see phy devices of this cards and configure them, but I have some troubles with setting wifi region for my wifi cards.
I use 'iw reg set ' command, but it doesn't work. I don't receive any logs to dmesg, and 'iw reg get' always returns information that I have a 'global' region. I have tried to use kmod-cfg80211 and kmod-mac80211 OPENWRT packages aka 'compat-wireless' package instead of kernel packages, but when I used OPENWRT packages, I couldn't find my phy devices at all.

Do you have any ideas how I can fix this?


  1. I also use CONFIG_CFG80211_INTERNAL_REGDB option, because I can't install 'crda' package.
  2. Link to the compat-wireless package -

@vvinogradov, welcome to the community!

Did you attempt setting the country in the proper OpenWrt config file?

Thank you.
I changed it but it didn't work. I found that wifi config is being parsed by UCI and UCI triggers a script that uses 'iw reg set ' command.

1 Like

Knowing which wireless cards/chips you're using might help.

That you can't install the "standard" database and are using an internal one may also be a source of problems. (I don't see a "crda" package, so I assume that you're talking of the wireless-regdb package)

"custom OPENWRT LEDE v17.01.2" is very outdated and effectively unsupported at this time. Working from at least 19.07 or master would be suggested.

@jeff, I use rtl8723bu embedded chip and mPCI wifi card.

I don't have the wireless-regdb package. I use kernel mac80211 and cfg80211 packages with CONFIG_CFG80211_INTERNAL_REGDB option. I have tried to install wireless-regdb package manually, but it didn't work