Change interface br-lan from 100 mb to 1 gigabit. Help me

I use router linksys ea3500 with firmware openwrt-18.06 brunch.

swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
Port 0:
        mask: 0x0000: (0)
        qmode: 3
        pvid: 1
        link: port:0 link:up speed:100baseT full-duplex
Port 1:
        mask: 0x0000: (1)
        qmode: 3
        pvid: 1
        link: port:1 link:down
Port 2:
        mask: 0x0000: (2)
        qmode: 3
        pvid: 1
        link: port:2 link:down
Port 3:
        mask: 0x0000: (3)
        qmode: 3
        pvid: 1
        link: port:3 link:down
Port 4:
        mask: 0x0000: (4)
        qmode: 3
        pvid: 2
        link: port:4 link:up speed:100baseT full-duplex
Port 5:
        mask: 0x0000: (5)
        qmode: 3
        pvid: 0
        link: port:5 link:up speed:1000baseT full-duplex
Port 6:
        mask: 0x0000: (6)
        qmode: 3
        pvid: 0
        link: port:6 link:up speed:1000baseT full-duplex
VLAN 1:
        port_based: 0
        vid: 1
        ports: 0 1 2 3 5t
VLAN 2:
        port_based: 0
        vid: 2
        ports: 4 6t

I had a gigabit local network on the stock firmware.
And now no more than 100 megabits?
Please, help to return back the gigabit speed in the local network.

First, are all the devices gigabit? The numbering in the switch may not match those on the case.

There usually isn't any way to configure ports to run slower than the speed they automatically determine as the highest supported by both devices. So it's not a misconfiguration issue.

A faulty cable can make gigabit devices fall back the 100M. Gigabit operation needs all of the wires in the cable while 100M uses only half of them.

2 Likes

You are absolutely right, maybe it's the physical limitations of my cables. On the previous firmware, I measured the iperf3 in my local network on the same hardware, it was about 900 mbps.
I can not understand why the speed on the LAN-Wifi bridge is always limited to about 95 mbps, with a connection of 270 Mbit (5Hz).
I think that this is a soft limit of 100 Mbps on the inside Switch.
Do you think it's possible to switch its software to full speed of 1000 mbps?

Im using Cat6 Ethernet cables, and measure with iperf3 fom my MacPro2013 to LinksysWRT 32x with OpenWRT 18.06.1 -> 112 to 113 MB/sec, during my MacPro isnt attached directly to the WRT32X, I have a Netgear GigabitSwitch inbetween that is uplinked to the WRT32X..now, my other Gigabit Macs are attached also to the Netgear GigabitHub, under those devices, that connect directly under each other without passing through the WRt32X I get full 122 MB/sec ..nearly full saturation of GigaBitSpeed

If your cables are OK, and comply with at less cat5e cables or better cat6 ...and your devices are Gigabit capable, it should automaticly use/connect with 1000 MBit/sec!

1 Like

I completely agree. I think that my vlan limits all my interfaces.
Am I mistaken?

I dont see a reason, why VLAN setup should cause a massive speed drop ( unless you did something to limit speeds, like limiting LinkSpeeds on ceratin ports).... first of all, physics layers should be checked, means, cables are OK (CAT5e or 6), check if my interfaces are GigaBit capable, and then check out if there is maybe a software problems somewhere, also a good read is this doc by CISCO: https://www.cisco.com/c/en/us/support/docs/lan-switching/ethernet/10561-3.html

I just checked my setup client side on en0 Ethernet Interface, it says: Speed= 1000baseT, Duplex= FullDuplex, Flowcontrol enabled
On the Router, I did nothing, it autoselects by itself to 1000 MBit asap I plug in a GigabitDevice, never had to care about it

Good Luck!

~# ethtool eth0
Settings for eth0:
        Supported ports: [ MII ]
        Supported link modes:   Not reported
        Supported pause frame use: No
        Supports auto-negotiation: No
        Supported FEC modes: Not reported
        Advertised link modes:  Not reported
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Supports Wake-on: d
        Wake-on: d
        Link detected: yes

Maybe the driver does not know that the switch can 1000?

I replaced the cable, everything worked at a speed of 1 gigabit.
Thanks to everyone who answered my request.
I thought it was me that something is wrong configured in the router, but it turned out was defective cable.
The entire project operwrt force in people!

2 Likes

Glad you could solve with new cables, another Tip, try not to make hard corners with Ethernet cables...better wide radius without makeing in the cable 90 degrees angles knicks...it damages and can break shielding and make the cable more vulnerable against other magentic fields that may be arround and disturb the signal and quality of the data that travels though the cable.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.