Carambola2 connect ethernet port ıssue

hi, carambola2 connect serial port (usb) but not connect ethernet port. How can i connect using putty or hyperterminal ? (using ssh)

What is the output of the following commands?
uci export network; uci export dhcp; uci export firewall; ip -4 addr

image0

https://drive.google.com/drive/folders/1Tjr2ivF2qWIfCCARom-LLwR_ksjCEiZJ

Please edit the posts above and paste here the output in preformatted text (the </> button)

1 Like
type or paste code here
```root@OpenWrt:/# uci export network
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd99:5d77:fecc::/48'

config interface 'lan'
        option ifname 'eth0'
        option proto 'none'

config interface 'wifi'
        option ifname 'wlan0'
        option master 'bat0'
        option proto 'batadv_hardif'
        option mtu '2304'

config interface 'bridge'
        option ifname 'bat0 eth0'
        option proto 'static'
        option type 'bridge'
        option netmask '255.255.255.0'
        option ipaddr '169.254.188.11'

config interface 'bat0'
        option proto 'batadv'
        option aggregated_ogms '1'
        option bridge_loop_avoidance '0'
        option distributed_arp_table '1'
        option fragmentation '1'
        option gw_mode 'off'
        option hop_penalty '30'
        option log_level '15'
        option multicast_mode '1'
        option network_coding '1'
        option routing_algo 'BATMAN_V'
        option orig_interval '5000'
        option elp_interval '5000'
        option mcast_rate '18000'

root@OpenWrt:/# uci export dhcp
package dhcp

config dnsmasq
        option port '0'
        option authoritative '1'

config dhcp 'lan'
        option interface 'bridge'
        option networkid 'eth0'
        option start '11'
        option limit '1'
        option leasetime '12h'
        option ra 'disabled'
        option dhcpv6 'disabled'
        option dynamicdhcp '0'
        option force '1'

config host
        option name '_1'
        option ip '169.254.188.2'
        option mac '00:80:0F:95:19:02'

config host
        option name '_2'
        option ip '169.254.188.4'
        option mac '00:80:0f:95:19:04'

config host
        option name '_3'
        option ip '169.254.188.6'
        option mac '00:80:0F:95:19:06'

config host
        option name '_4'
        option ip '169.254.188.8'
        option mac '00:80:0F:95:19:08'

config host
        option name '_5'
        option ip '169.254.188.10'
        option mac '00:80:0F:95:19:0A'

config host
        option name '_6'
        option ip '169.254.188.12'
        option mac '00:80:0F:95:19:0C'

config host
        option name '_7'
        option ip '169.254.188.14'
        option mac '00:80:0F:95:19:0E'

config host
        option name '_8'
        option ip '169.254.188.16'
        option mac '00:80:0F:95:19:10'

config host
        option name '_9'
        option ip '169.254.188.18'
        option mac '00:80:0f:95:19:12'

config host
        option name '_10'
        option ip '169.254.188.20'
        option mac '00:80:0F:95:19:14'

config host
        option name '_11'
        option ip '169.254.188.22'
        option mac '00:80:0F:95:19:16'

config host
        option name '_12'
        option ip '169.254.188.24'
        option mac '00:80:0F:95:19:18'

config host
        option name '_13'
        option ip '169.254.188.26'
        option mac '00:80:0F:95:19:1A'

config host
        option name '_14'
        option ip '169.254.188.12'
        option mac '64:00:6A:8B:3C:FE'

root@OpenWrt:/# uci export firewall
package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

root@OpenWrt:/# ip -4 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
5: br-bridge: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
qlen 1000
    inet 169.254.188.11/24 brd 169.254.188.255 scope global br-bridge
       valid_lft forever preferred_lft forever
root@OpenWrt:/#
general

Please put the text in preformatted format. Edit the post (click the pencil), then select all the text of the post and press the </> button.

1 Like

Did you configure all these things or you bought the device from someone else preconfigured?
There are a lot of mistakes in there and I am not sure if there is point to start correcting or reset configuration and start from scratch.

1 Like

I bought the device from someone else preconfigured. I can reach USB port but i can't reach Ethernet port.

Type firstboot and reboot to reset it to defaults.

1 Like