Can't using more than one pppoe over fiber on switch port

My isp fiber modem/router have in bridge mode, using vlan3x, my isp bind vlan3x to all modem ports untagged. If I create more than one pppoe on a switch port, it will drop or can't connect all.
If I connect pppoe1 by wan port & pppoe2 by switch port, it working well.
Here my network config:

config interface 'wan'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option ifname 'eth1.2'
        option username 'user1'
        option password 'pass1'
        option macaddr 'F8:1A:67:12:32:24'
        option pppd_options 'debug'

config interface 'wan2'
        option proto 'pppoe'
        option ifname 'eth1.3'
        option username 'user2'
        option password 'pass2'
        option macaddr 'F8:1A:67:12:23:34'
        option pppd_options 'debug'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 4'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0t 2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '0t 3'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option ipaddr '172.16.16.1'

Test on ag300h, wr841n, wr941n router same issue.