Can't use image builder due to library version changes

Hi,

I have been trying to use the 21.02.0-rc2 image builder (tried for wrt1200ac and r7800 targets), but I am getting errors due to some new library package versions:

 * pkg_hash_fetch_best_installation_candidate: Packages for libiwinfo20210106 found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for iwinfo:
 *      libubus20210215
 * opkg_install_cmd: Cannot install package iwinfo.

It seems that some library package versions (most notably libubox and libubus) have changed since the 21.02.0-rc2 release, and that this is causing build issues with the image builder.

I am also seeing some binary packages have since been reuploaded, with the same version number, but now depending on the new library package versions. For example, at some point the binary package for libuci20130104 version 2020-10-06-52bbc99f-4 depended on libubox20201212, and now the binary package has been replaced (but the version number hasn't changed) and the new package depends on libubox20210516 instead.

So I have a few questions:

  • is it normal/expected for binary packages to be reuploaded, with the same version number, but not the exact same contents and/or dependencies ?
  • Can I expect the image builder to start working again sometime soon, maybe after some of the binary packages have been reuploaded to depend on the current rather than the old libubox and libubus versions ? What would be the expected timeline for this to happen ?
  • Is this sort of breakage something that is expected during the -rc cycles, but shouldn't happen after 21.02.0 is released ? Or, does it sound like I am doing something wrong which I should fix on my end ?

See 21.02.0-rc2 - Build Error on libubus20210215 for some more info on this subject.

3 Likes

Thank you so much for the link.

Trying to summarize what I read:

  • This is a known issue
  • Just waiting for mirrors to update won't solve it - the issue is due to a version mismatch between target specific packages (which are frozen with a given release version) and shared packages (which keep updating with the 21.02 branch)
  • This has happened before, but usually not during the official cycle of a release (i.e. typically not after a .0 release is made)
  • Some changes are being proposed to reclassify some shared packages as target specific so that the issue will be less likely to happen again
1 Like

You understood it correctly.

And these are the packages that are concerned with the issue:
https://lists.openwrt.org/pipermail/openwrt-devel/2021-June/035442.html

EDIT:
note that the full toolchain works normally to build stuff from sources. This only concern the imagebuilder.

1 Like