Can't SSH or Web In After Firmware Upgrade

I just upgraded my C2600 from 18.6.1 to 18.6.4 via LUCI. The router took a long time and seemed to not take the update so I powered off the router and powered it back on. The router is back up and internet service is available through all wired and wireless but I can't ssh or web into the router. Am I in failsafe? This hasn't happened before to me.

ssh is available in failsafe, actually it's the only method to connect to your router at all while failsafe is enabled (aside from serial console access, which is rather complicated on your device).

I'd suggest to try explicitly invoking and to do another sysupgrade -n /tmp/openwrt-*-sysupgrade.bin (-n do not save configuration over reflash) from there. The files to use for sysupgrading would be (either or, I'd suggest to go with 19.07.0-rc1 over 18.06.5, but that's your decision):

If that doesn't work, give push-button tftp recovery a try, which should 'always' work on your device. The files to use for push-button tftp recovery would be (either or, I'd suggest to go with 19.07.0-rc1 over 18.06.5, but that's your decision); respectively using the OEM firmware (I'd recommend to go with OpenWrt's factory image though, less confusion about bootloaders):

Very strange. No matter what I tried it wouldn't work. Everything appeared up and operational just no ssh, 80 or 443 access to LUCI or console. So I did a push button factory reset and boom. Right in to fresh firmware. I tried to install a backed up configuration, and same thing. Locked out. So I had to do another push button reset and I guess I have to rebuild my config from scratch :frowning:

I don't know if this is the case with your C2600, but i used to have a Linksys EA3500 and with the 18.06.* builds i'd get locked out after every upgrade, no ssh, no Luci, finally discovered that after upgrading i just needed to "refresh" my connection by turning off the wired connection on my comp for a few seconds, then turning it back on, once back on i'd have access again, have no idea if that will work for you, but might be worth a try if you run into the same problem again.

I didn't try from another host but I'm pretty sure I did pull the Ethernet cable and plug it back in. Also I could ping my router no problem....oh well such is life. I've messed with it so much a rebuild outside the static DHCP list is a 10 min job. Just my OCD kicking it. Inquiring minds want to know!!!

It's kind of hard to explain, but by turning off the wired connection i mean going into network settings on your comp and turning it off from there, if that makes sense, unplugging the cable didn't work for me either, neither did reboot, i always had to reset like you did until i discovered the turning off wired connection thing.

Might make a little more sense with a screenshot -