Can't ssh into OpenWrt on a raspberry pi 4

I'm using a raspberry pi 4 and I'm facing a problem where I can't connect via ssh

So here's the steps I've done to my raspberry pi to connect it the first time

Installed Open WRT on the sd card

Booted the raspberry pi

Connected my pi directly to my pc via Ethernet

Setting Ethernet adapter settings to a static ip of
And a gateway

Opened CMD then ssh into the pi ssh root@

Then it worked after that I played around with the configuration of the pi and rebooted it then I got no luck connecting via ssh

After all of that I tried to wipe open WRT and install a fresh one on the sd card but I still couldn't get it to connect like the first time.

What did you change? This is key... without knowing the exact changes you made, it is not clear how to advise you with respect to the network settings or how to get your ssh sessions working again.

You could connect a display and keyboard to your Pi and you should be able to use the terminal.

1 Like

hello there, so the only thing I did is change the LAN interface IP address by entering the command vi network and then editing the default IP address in the LAN from to and then I saved it by using the escape key then :wq

so did I do something that messed up with my pc settings?, because even after deleting OpenWrt and installing a new one I couldn't get it to connect

This should not have affected your pc settings, but after changing the openwrt address, did you renew your dhcp lease or try setting a static ip (on the pc) to ensure that the pc has the network settings updated accordingly?

1 Like

Here is how Solved the problem

Restarted my pc while keeping the Ethernet from my raspberry pi disconnected

Disconnected my pc from other connections

Set my ip address on the pc to DHCP

Entered ipconfig command

Then I saw that it changed the ip gateway from to what's confusing to me that even after formatting the sd card using the raspberry pi imager utility on windows my raspberry pi still asked me for the password I sat the first time when I ssh into it

But the problem is solved thank you everyone

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.