Can't share internet to my openwrt router

hey guys, I got a new topic for you. I am from an old post but I think its better to close the old one, because it's answered.

My goal
share the internet connection from my macOS to my openwrt router. So I can download some packages. The main goal is to download the following packages:

  • tcpdump

  • nano

  • openvsswitch

Settings
ive connected my Mikrotik with openWrt 23.05.03 to my Macbook via lan. The MacBook is connected to the internet via wifi.
My Mikrotik got on the wan port the ip address 10.10.1.200
My Laptop got on the lan interface the ip address 10.10.1.201
The connection before sharing internet is possible.
The Mikrotik has the following network settings:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc0:e5b6:24a8::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'lan5'
        list ports 'wan'

config device
        option name 'lan2'
        option macaddr '48:a9:8a:ec:b1:72'

config device
        option name 'lan3'
        option macaddr '48:a9:8a:ec:b1:72'

config device
        option name 'lan4'
        option macaddr '48:a9:8a:ec:b1:72'

config device
        option name 'lan5'
        option macaddr '48:a9:8a:ec:b1:72'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '10.10.1.200'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.10.1.201'
        list dns '8.8.8.8'

config device
        option name 'wan'
        option macaddr '48:a9:8a:ec:b1:71'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'wan'

config bridge-vlan
        option device 'br-lan'
        option vlan '2'
        list ports 'lan2'

config bridge-vlan
        option device 'br-lan'
        option vlan '3'
        list ports 'lan3'

config bridge-vlan
        option device 'br-lan'
        option vlan '4'
        list ports 'lan4'

config bridge-vlan
        option device 'br-lan'
        option vlan '5'
        list ports 'lan5'

config interface 'ovs2'
        option proto 'none'
        option device 'br-lan.2'
        option force_link '1'

config interface 'ovs3'
        option proto 'none'
        option device 'br-lan.3'
        option force_link '1'

config interface 'ovs4'
        option proto 'none'
        option device 'br-lan.4'
        option force_link '1'

config interface 'ovs5'
        option proto 'none'
        option device 'br-lan.5'
        option force_link '1'

config route
        option interface 'ovs2'
        option target '0.0.0.0/24'
        option gateway '10.10.1.201'

Problems
so I thought it would be easy when I share my internet connection from my MacBook the the Mikrotik. When I share the connection I can't connect to openwrt again.

So I tried to install the packages first on my MacBook then upload it via the gui. For that i need to find out what architecture my router board gr3 has. On this site https://openwrt.org/toh/views/toh_packagedownload they say the RB750g3 has the build : mipsel_1004kc. But on the download page I can't find the packages : https://downloads.openwrt.org/releases/packages-23.05/. So this idea doesn't work.

Intenet Sharing

so after that I looked on the routing tables. Here is a problem, after I start sharing my internet connection to the Mikrotik the route to the subnet 10.10.1.0 is gone. The lan interfaces ip is gone too.

These are the routing tables when internet sharing is switched on :

Internet:
Destination        Gateway            Flags               Netif Expire
default            (ip address of the wifi interface)     UGScg                 en0
default            link#18            UCSIg           bridge100      !
127                127.0.0.1          UCS                   lo0
127.0.0.1          127.0.0.1          UH                    lo0
169.254            link#6             UCS                   en0      !
192.168.2          link#18            UC              bridge100      !

That's not all of the routes, the others are not important. Here is the interface which is normally my lan interface:

en5: flags=8b63<UP,BROADCAST,SMART,RUNNING,PROMISC,ALLMULTI,SIMPLEX,MULTICAST> mtu 1500
	options=6464<VLAN_MTU,TSO4,TSO6,CHANNEL_IO,PARTIAL_CSUM,ZEROINVERT_CSUM>
	ether a0:ce:c8:c7:68:ef
	nd6 options=201<PERFORMNUD,DAD>
	media: autoselect (1000baseT <full-duplex>)
	status: active

The routing table looks like this when internet sharing is off:

Internet:
Destination        Gateway            Flags               Netif Expire
default            (wlan interface ip)      UGScIg                en0
10.10.1/24         link#11            UCS                   en5      !
10.10.1.201/32     link#11            UCS                   en5      !
127                127.0.0.1          UCS                   lo0
127.0.0.1          127.0.0.1

The lan interface looks like this:

en5: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	options=6464<VLAN_MTU,TSO4,TSO6,CHANNEL_IO,PARTIAL_CSUM,ZEROINVERT_CSUM>
	ether a0:ce:c8:c7:68:ef
	inet6 (unimportant)
	inet6 
	inet 10.10.1.201 netmask 0xffffff00 broadcast 10.10.1.255
	nd6 options=201<PERFORMNUD,DAD>
	media: autoselect (1000baseT <full-duplex>)
	status: active

Solution
a nice solution would be, that I can share the Internet but the main goal is installing the packages.

Go to https://firmware-selector.openwrt.org/, select your device, add the packages you want to the package list, and generate a new sysupgrade image.

Flash the new sysupgrade image.

1 Like

just adding them like ".....-nano-openvswitch-tcpdump" ?

No -, it means remove (exclude).

oh okay, then just ".. nano openvswitch tcpdump" ?

Yes, that's right.

oh ok thanks, that worked!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.