Can't set up wan on PPPoE

Hi. I am new to OpenWRT so bear with me. I flashed my TP-Link Archer C6 with OpenWRT successfully, but I am having a hard time setting up PPPoE on VLAN ID 848 with username/pwd wia/wia.

After a fresh factory reset, I followed the tutorials by setting up the device of pre-created wan interface to eth0.848, change the protocol to PPPoE and put the credentials in. My config looks like this now:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd49:e5fc:83af::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.848'
	option proto 'pppoe'
	option username 'wia'
	option password 'wia'
	option ipv6 'auto'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

However, all I see in that interface is Error: Connection attempt failed. In the logs, I see:

Mon
  Mon Oct  9 21:58:10 2023 daemon.notice netifd: Interface 'wan' is disabled
  Mon Oct  9 21:58:10 2023 daemon.notice netifd: Interface 'wan' is enabled
  Mon Oct  9 21:58:10 2023 daemon.notice netifd: Interface 'wan' is setting up now
  Mon Oct  9 21:58:10 2023 daemon.info pppd[3748]: Plugin pppoe.so loaded.
  Mon Oct  9 21:58:10 2023 daemon.info pppd[3748]: PPPoE plugin from pppd 2.4.9
  Mon Oct  9 21:58:10 2023 daemon.notice pppd[3748]: pppd 2.4.9 started by root, uid 0
  Mon Oct  9 21:58:11 2023 daemon.warn odhcpd[1490]: No default route present, overriding ra_lifetime!
  Mon Oct  9 21:58:23 2023 daemon.err pppd[3748]: select (waitForPADO): Interrupted system call
  Mon Oct  9 21:58:23 2023 daemon.warn pppd[3748]: Timeout waiting for PADO packets
  Mon Oct  9 21:58:23 2023 daemon.err pppd[3748]: Unable to complete PPPoE Discovery
  Mon Oct  9 21:58:23 2023 daemon.info pppd[3748]: Exit.
  Mon Oct  9 21:58:23 2023 daemon.notice netifd: Interface 'wan' is now down
  Mon Oct  9 21:58:23 2023 daemon.notice netifd: Interface 'wan' is disabled
  Mon Oct  9 21:58:23 2023 daemon.notice netifd: Interface 'wan' is enabled
  Mon Oct  9 21:58:23 2023 daemon.notice netifd: Interface 'wan' is setting up now
  Mon Oct  9 21:58:23 2023 daemon.info pppd[3874]: Plugin pppoe.so loaded.
  Mon Oct  9 21:58:23 2023 daemon.info pppd[3874]: PPPoE plugin from pppd 2.4.9
  Mon Oct  9 21:58:23 2023 daemon.notice pppd[3874]: pppd 2.4.9 started by root, uid 0
  Mon Oct  9 21:58:24 2023 daemon.warn odhcpd[1490]: No default route present, overriding ra_lifetime!
  Mon Oct  9 21:58:38 2023 daemon.warn pppd[3874]: Timeout waiting for PADO packets
  Mon Oct  9 21:58:38 2023 daemon.err pppd[3874]: Unable to complete PPPoE Discovery
  Mon Oct  9 21:58:38 2023 daemon.info pppd[3874]: Exit.
  Mon Oct  9 21:58:38 2023 daemon.notice netifd: Interface 'wan' is now down
  Mon Oct  9 21:58:38 2023 daemon.notice netifd: Interface 'wan' is disabled
  Mon Oct  9 21:58:38 2023 daemon.notice netifd: Interface 'wan' is enabled
  Mon Oct  9 21:58:38 2023 daemon.notice netifd: Interface 'wan' is setting up now
  Mon Oct  9 21:58:39 2023 daemon.info pppd[3995]: Plugin pppoe.so loaded.
  Mon Oct  9 21:58:39 2023 daemon.info pppd[3995]: PPPoE plugin from pppd 2.4.9
  Mon Oct  9 21:58:39 2023 daemon.notice pppd[3995]: pppd 2.4.9 started by root, uid 0
  Mon Oct  9 21:58:39 2023 daemon.warn odhcpd[1490]: No default route present, overriding ra_lifetime!

The cable from the ISP's terminator is going straight into the WAN port.

I tried deleting the wan (and wan6) interfaces, and created the eth0.848 device manually, then PPPoE interface connecting to this device (while adding the interface to wan in firewall). I haven't done any other changes to the configuration:

  config interface 'loopback'  
  	option device 'lo'  
  	option proto 'static'  
  	option ipaddr '127.0.0.1'  
  	option netmask '255.0.0.0'  
  
  config globals 'globals'  
  	option ula_prefix 'fd49:e5fc:83af::/48'  
  
  config device  
  	option name 'br-lan'  
  	option type 'bridge'  
  	list ports 'eth0.1'  
  
  config interface 'lan'  
  	option device 'br-lan'  
  	option proto 'static'  
  	option ipaddr '192.168.1.1'  
  	option netmask '255.255.255.0'  
  	option ip6assign '60'  
  
  config switch  
  	option name 'switch0'  
  	option reset '1'  
  	option enable_vlan '1'  
  
  config switch_vlan  
  	option device 'switch0'  
  	option vlan '1'  
  	option ports '2 3 4 5 0t'  
  
  config switch_vlan  
  	option device 'switch0'  
  	option vlan '2'  
  	option ports '1 0t'  
  
  config device  
  	option type '8021q'  
  	option ifname 'eth0'  
  	option vid '848'  
  	option name 'eth0.848'  
  
  config interface 'wan'  
  	option proto 'pppoe'  
  	option device 'eth0.848'  
  	option username 'wia'  
  	option password 'wia'  
  	option ipv6 'auto'

However, I still didn't get the connection. What am I doing wrong? Thanks a lot!

You forgot to configure the switch switch0 and defined VLAN 848 to make the traffic flow to the CPU. The CPU (or Linux) did not receive any data from that VLAN, and that's why it did not work.

2 Likes

Change this section to be:

config switch_vlan
	option device 'switch0'
	option vlan '848'
	option ports '1t 0t'

The two changes are to let VLAN848 pass through the switch, and change port 1 (the blue WAN port on the back of the router) to use tagged packets.

This can also be done in the GUI on the Network-> Switch page. Change the number on the left side from 2 to 848, then in that row, change the port from Untagged to Tagged.

OMG thanks!

This is what it solve for me:


d

Yes that is the proper setup. You can now delete the VLAN ID row 2; it is no longer needed.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.