Can't ping (Diagnostics) on Dumb AP

Hey there,
I have a Xiaomi Mi Wifi MINI configured as a dumb AP in my setup.
The LAN devices and WiFi devices have a connection to the internet but the router seems to not be able to ping or traceroute to any website. (Nslookup works)
This is the network file


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config device
	option name 'br-lan'
	option type 'bridge'
	option ipv6 '0'
	list ports 'eth0'
	list ports 'eth0.1'
	list ports 'eth0.2'
	option bridge_empty '1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.98'
	option gateway '192.198.1.1'
	option broadcast '192.168.1.255'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	list dns '192.168.1.1'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config device
	option name 'eth0'
	option ipv6 '0'

config device
	option name 'eth0.1'
	option type '8021q'
	option ifname 'eth0'
	option vid '1'
	option ipv6 '0'

config device
	option name 'eth0.2'
	option type '8021q'
	option ifname 'eth0'
	option vid '2'
	option ipv6 '0'

config device
	option name 'wlan0'
	option ipv6 '0'

config device
	option name 'wlan1'
	option ipv6 '0'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 1 0 4'
	option vid '1'

This is my first attempt with OpenWRT, I'm sure I missed something but I can't figure out what I missed. (The 2 VLANs are there from stock config, so I didn't touch them) (I don't have ipv6 enabled on the main router and I don't plan using it unless it's necessary)

did you DIY, or did you follow https://openwrt.org/docs/guide-user/network/wifi/dumbap ?

and how is it connected to the main router, and what's the LAN subnet on the main router ?

Typo in 2nd octet, should be 168

3 Likes

excellent spotting !

1 Like

This is like the 10th time I reconfigured the router. I remember looking at the document and at like 5 other topics here in the forum. Do I have something that shouldn't be there like the double VLAN?
To answer your question, even if I don't have the issue anymore, the router is connected via an ethernet cable to the ISP Router

Very good eye, didn't spot it this time I configured the router.
Now after 2+ months I can finally download packages.
(I had other problems the other times I configured the router)

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.