Can't ping address I use for gateway

Hi,

I segment my network into three networks. And at some point I was not able to ping my default gateway address any more.

I am able to access any IP address on 192.168.100.0/24 network from any network on OpenWrt router such as Raspberry Pi, except IP address of ISP router.

It must be some configuration issue, because when I reset settings I am able to access ISP router and hence the Internet.

Network config:


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5b:e658:8619::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan5'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.110.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.100.1'

config interface 'wan'
        option device 'eth1'
        option proto 'static'
        option ipaddr '192.168.100.2'
        option netmask '255.255.255.0'
        option gateway '192.168.100.1'

config device
        option type 'bridge'
        option name 'br-guest'
        option bridge_empty '1'

config interface 'guest'
        option proto 'static'
        option device 'br-guest'
        option ipaddr '192.168.130.1'
        option netmask '255.255.255.0'
        option gateway '192.168.100.1'

config device
        option type 'bridge'
        option name 'br-work'
        option bridge_empty '1'
        list ports 'lan4'

config interface 'work'
        option proto 'static'
        option device 'br-work'
        option ipaddr '192.168.120.1'
        option netmask '255.255.255.0'
        option broadcast '192.168.100.1'

config device
        option name 'eth1'
        option ipv6 '0'

Remove the gateway from here:

And remove it from here, too:

and remove the broadcast from this (it's both unnecessary and also incorrect):

Then restart and test again.

2 Likes

Thank you. I removed broadcast address and it works as expected now!
That broadcast address is obliviously wrong. I probably selected wrong field in luci when I was entering default gateway.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.