Can't opkg update after install / Connectivity issues

I've just installed the OpenWrt/06-06-2020 snapshot from OpenWRTInvasion in a Xiaomi Router 4A Gigabit edition. Since there is no stable release, I had to use the snapshot. The installation seems to complete OK, and I connected the Xiaomi router to my Asus main router (running AdvancedTomato), but I can only SSH into the Xiaomi router directly through a cable, not through other computers on the network. Also, once I've ssh'd into it , I can ping, for example, 8.8.8.8, but I can't use opkg to update or to install luci. I get these errors:

Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/Packages.gz
Failed to establish connection
*** Failed to download the package list from http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/Packages.gz

Note: I had to uci set network.wan.dns="1.1.1.1" to be able to have connectivity. For some reason the Xiaomi router didn't get the dns from the main router. And, despite having Internet connection on the laptop connected to the Xiaomi, I can't update/install luci on the Xiaomi from ssh. Also, wget works only sometimes, which is weird.

It seems some network configuration problem. Any ideas?

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
2 Likes
root@OpenWrt:~# uci export network; uci export dhcp; uci export firewall; \
> head -n -0 /etc/firewall.user; \
> ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
> ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8f:863e:d549::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'lan1 lan2'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'wan'
	option proto 'dhcp'
	option dns '1.1.1.1'

config interface 'wan6'
	option ifname 'wan'
	option proto 'dhcpv6'

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
5: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.51/24 brd 192.168.1.255 scope global wan
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
default via 192.168.1.1 dev wan  src 192.168.1.51 
192.168.1.0/24 dev br-lan scope link  src 192.168.1.1 
192.168.1.0/24 dev wan scope link  src 192.168.1.51 
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1 
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1 
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1 
broadcast 192.168.1.0 dev br-lan table local scope link  src 192.168.1.1 
broadcast 192.168.1.0 dev wan table local scope link  src 192.168.1.51 
local 192.168.1.1 dev br-lan table local scope host  src 192.168.1.1 
local 192.168.1.51 dev wan table local scope host  src 192.168.1.51 
broadcast 192.168.1.255 dev br-lan table local scope link  src 192.168.1.1 
broadcast 192.168.1.255 dev wan table local scope link  src 192.168.1.51 
0:	from all lookup local 
32766:	from all lookup main 
32767:	from all lookup default 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2ad1:27ff:fedb:2cb4/64 scope link 
       valid_lft forever preferred_lft forever
5: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2ad1:27ff:fedb:2cb5/64 scope link 
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd8f:863e:d549::1/60 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::2ad1:27ff:fedb:2cb4/64 scope link 
       valid_lft forever preferred_lft forever
fd8f:863e:d549::/64 dev br-lan  metric 1024 
unreachable fd8f:863e:d549::/48 dev lo  metric 2147483647 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev wan  metric 256 
fe80::/64 dev br-lan  metric 256 
local ::1 dev lo table local  metric 0 
anycast fd8f:863e:d549:: dev br-lan table local  metric 0 
local fd8f:863e:d549::1 dev br-lan table local  metric 0 
anycast fe80:: dev eth0 table local  metric 0 
anycast fe80:: dev wan table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
local fe80::2ad1:27ff:fedb:2cb4 dev eth0 table local  metric 0 
local fe80::2ad1:27ff:fedb:2cb4 dev br-lan table local  metric 0 
local fe80::2ad1:27ff:fedb:2cb5 dev wan table local  metric 0 
ff00::/8 dev eth0 table local  metric 256 
ff00::/8 dev br-lan table local  metric 256 
ff00::/8 dev wan table local  metric 256 
0:	from all lookup local 
32766:	from all lookup main 
4200000001:	from all iif lo lookup unspec 12
4200000005:	from all iif wan lookup unspec 12
4200000006:	from all iif br-lan lookup unspec 12
lrwxrwxrwx    1 root     root            16 Jun  6  2020 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 Dec  8 11:32 /tmp/resolv.conf
-rw-r--r--    1 root     root            58 Jun  6  2020 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root            58 Jun  6  2020 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface wan
nameserver 1.1.1.1
nameserver 192.168.1.1
uci set network.lan.ipaddr="192.168.2.1"
uci commit network
/etc/init.d/network restart
2 Likes

That was really helpful, thank you so much. What was the exact problem? Does that command set the subnet ip? Now opkg update works, but opkg install luci yields:

root@OpenWrt:~# opkg install luci
Installing luci (git-20.074.84698-ead5e81) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/luci_git-20.074.84698-ead5e81_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * opkg_install_cmd: Cannot install package luci.

I guessed I had to upgrade, so tried opkg upgrade to find there's no such option. Searching on stackoverflow found:

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade 

But that gave a lot of errors while upgrading:

root@OpenWrt:~# opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade 
Upgrading opkg on root from 2020-05-07-f2166a89-1 to 2020-11-25-66f458de-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/opkg_2020-11-25-66f458de-1_mipsel_24kc.ipk
Upgrading ubus on root from 2020-02-05-171469e3-1 to 2020-12-04-d1d9ddf9-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/ubus_2020-12-04-d1d9ddf9-1_mipsel_24kc.ipk
Upgrading libuci20130104 on root from 2020-04-24-ec8d3233-3 to 2020-10-06-52bbc99f-3...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/libuci20130104_2020-10-06-52bbc99f-3_mipsel_24kc.ipk
Upgrading busybox on root from 1.31.1-1 to 1.31.1-7...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/busybox_1.31.1-7_mipsel_24kc.ipk
Error loading shared library libjson-c.so.5: No such file or directory (needed by /bin/ubus)
Error loading shared library libjson-c.so.5: No such file or directory (needed by /bin/ubus)
Upgrading kmod-nf-reject6 on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-nf-reject6_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-nf-flow on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-nf-flow_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-lib-crc-ccitt on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-lib-crc-ccitt_5.4.81-1_mipsel_24kc.ipk
Upgrading getrandom on root from 2019-12-31-0e34af14-3 to 2020-10-25-9ef88681-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/getrandom_2020-10-25-9ef88681-1_mipsel_24kc.ipk
Upgrading kmod-pppoe on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-pppoe_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-pppox on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-pppox_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-ipt-conntrack on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-ipt-conntrack_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-nf-reject on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-nf-reject_5.4.81-1_mipsel_24kc.ipk
Upgrading base-files on root from 222-r13499-7b4877c204 to 239-r15165-66d12ce667...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/base-files_239-r15165-66d12ce667_mipsel_24kc.ipk
procd was autoinstalled and is now orphaned, removing.
Removing package procd from root...
/etc/rc.common: .: line 115: can't open '/lib/functions/procd.sh': No such file or directory
/etc/rc.common: .: line 115: can't open '/lib/functions/procd.sh': No such file or directory
umount: devpts busy - remounted read-only
umount: tmpfs busy - remounted read-onlyroot@OpenWrt:~# opkg update
Downloading https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/kmods/5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/kmods/5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/freifunk/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/freifunk/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.gz

Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.gz
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.gz

Collected errors:
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/kmods/5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/freifunk/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/packages/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/routing/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/telephony/Packages.gz, wget returned 1.
umount: can't remount overlayfs:/overlay read-only
umount: can't remount tmpfs read-only
umount: proc busy - remounted read-only
Upgrading kmod-nf-nat on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-nf-nat_5.4.81-1_mipsel_24kc.ipk
Upgrading netifd on root from 2020-06-04-db275e12-1 to 2020-11-30-42c48866-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/netifd_2020-11-30-42c48866-1_mipsel_24kc.ipk
Installing libnl-tiny1 (2020-08-05-c291088f-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/libnl-tiny1_2020-08-05-c291088f-1_mipsel_24kc.ipk
Upgrading dnsmasq on root from 2.81-3 to 2.82-10...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/dnsmasq_2.82-10_mipsel_24kc.ipk
/etc/rc.common: .: line 125: can't open '/lib/functions/procd.sh': No such file or directory
Installing procd (2020-12-04-6acc48c7-2) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/procd_2020-12-04-6acc48c7-2_mipsel_24kc.ipk
Installing libjson-c5 (0.15-1) to root...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/libjson-c5_0.15-1_mipsel_24kc.ipk
Upgrading libuclient20160123 on root from 2020-02-15-af585dbd-1 to 2020-06-17-c6609861-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/libuclient20160123_2020-06-17-c6609861-1_mipsel_24kc.ipk
Upgrading ubusd on root from 2020-02-05-171469e3-1 to 2020-12-04-d1d9ddf9-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/ubusd_2020-12-04-d1d9ddf9-1_mipsel_24kc.ipk
Upgrading firewall on root from 2019-11-22-8174814a-1 to 2020-09-05-8c2f9fad-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/firewall_2020-09-05-8c2f9fad-1_mipsel_24kc.ipk
Warning: Unable to locate ipset utility, disabling ipset support
 * Flushing IPv4 filter table
 * Flushing IPv4 nat table
 * Flushing IPv4 mangle table
 * Flushing IPv6 filter table
 * Flushing IPv6 mangle table
Upgrading kmod-nf-ipt on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-nf-ipt_5.4.81-1_mipsel_24kc.ipk
Upgrading ubi-utils on root from 2.1.1-1 to 2.1.2-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/ubi-utils_2.1.2-1_mipsel_24kc.ipk
Upgrading kmod-ip6tables on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-ip6tables_5.4.81-1_mipsel_24kc.ipk
Upgrading odhcp6c on root from 2020-03-28-f575351c-16 to 2020-12-03-faed29aa-16...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/odhcp6c_2020-12-03-faed29aa-16_mipsel_24kc.ipk
Upgrading fstools on root from 2020-05-12-84269037-1 to 2020-10-16-f25ab8a8-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/fstools_2020-10-16-f25ab8a8-1_mipsel_24kc.ipk
Upgrading uclient-fetch on root from 2020-02-15-af585dbd-1 to 2020-06-17-c6609861-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/uclient-fetch_2020-06-17-c6609861-1_mipsel_24kc.ipk
Upgrading uci on root from 2020-04-24-ec8d3233-3 to 2020-10-06-52bbc99f-3...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/uci_2020-10-06-52bbc99f-3_mipsel_24kc.ipk
Upgrading libubox20191228 on root from 2020-05-25-66195aee-1 to 2020-08-06-9e52171d-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/libubox20191228_2020-08-06-9e52171d-1_mipsel_24kc.ipk
Upgrading dropbear on root from 2019.78-5 to 2020.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/dropbear_2020.81-1_mipsel_24kc.ipk
Upgrading mtd on root from 25 to 26...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/mtd_26_mipsel_24kc.ipk
Upgrading odhcpd-ipv6only on root from 2020-05-04-5ce07702-3 to 2020-11-15-fb55e803-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/odhcpd-ipv6only_2020-11-15-fb55e803-1_mipsel_24kc.ipk
Installing libnl-tiny1 (2020-08-05-c291088f-1) to root...
Upgrading urandom-seed on root from 1.0-1 to 2...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/urandom-seed_2_mipsel_24kc.ipk
Upgrading ppp on root from 2.4.8.git-2020-05-25-2 to 2.4.8.git-2020-10-03-2...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/ppp_2.4.8.git-2020-10-03-2_mipsel_24kc.ipk
Upgrading kmod-leds-gpio on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-leds-gpio_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-gpio-button-hotplug on root from 5.4.43-3 to 5.4.81-3...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-gpio-button-hotplug_5.4.81-3_mipsel_24kc.ipk
Upgrading logd on root from 2019-12-31-0e34af14-3 to 2020-10-25-9ef88681-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/logd_2020-10-25-9ef88681-1_mipsel_24kc.ipk
Upgrading libjson-script on root from 2020-05-25-66195aee-1 to 2020-08-06-9e52171d-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/libjson-script_2020-08-06-9e52171d-1_mipsel_24kc.ipk
Upgrading libblobmsg-json on root from 2020-05-25-66195aee-1 to 2020-08-06-9e52171d-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/libblobmsg-json_2020-08-06-9e52171d-1_mipsel_24kc.ipk
Upgrading jshn on root from 2020-05-25-66195aee-1 to 2020-08-06-9e52171d-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/jshn_2020-08-06-9e52171d-1_mipsel_24kc.ipk
Upgrading kmod-ipt-core on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-ipt-core_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-ppp on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-ppp_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-nf-conntrack on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-nf-conntrack_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-nf-ipt6 on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-nf-ipt6_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-nf-conntrack6 on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-nf-conntrack6_5.4.81-1_mipsel_24kc.ipk
Upgrading ubox on root from 2019-12-31-0e34af14-3 to 2020-10-25-9ef88681-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/ubox_2020-10-25-9ef88681-1_mipsel_24kc.ipk
Removing obsolete file /sbin/lsmod.
Removing obsolete file /sbin/modprobe.
Removing obsolete file /sbin/rmmod.
Removing obsolete file /sbin/insmod.
Removing obsolete file /sbin/modinfo.
Upgrading libubus20191227 on root from 2020-02-05-171469e3-1 to 2020-12-04-d1d9ddf9-1...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/libubus20191227_2020-12-04-d1d9ddf9-1_mipsel_24kc.ipk
Upgrading kmod-ipt-offload on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-ipt-offload_5.4.81-1_mipsel_24kc.ipk
Upgrading kmod-slhc on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-slhc_5.4.81-1_mipsel_24kc.ipk
Upgrading ppp-mod-pppoe on root from 2.4.8.git-2020-05-25-2 to 2.4.8.git-2020-10-03-2...
Downloading http://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/ppp-mod-pppoe_2.4.8.git-2020-10-03-2_mipsel_24kc.ipk
Upgrading kmod-ipt-nat on root from 5.4.43-1 to 5.4.81-1...
Downloading http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/packages/kmod-ipt-nat_5.4.81-1_mipsel_24kc.ipk
Configuring libubox20191228.
Configuring libuclient20160123.
Configuring uclient-fetch.
Configuring opkg.
Configuring libubus20191227.
Configuring libjson-c5.
Configuring libblobmsg-json.
Configuring ubusd.
Configuring ubus.
Configuring libuci20130104.
Configuring busybox.
Failed to connect to ubus
Failed to connect to ubus
Failed to parse json data: unexpected end of data
Failed to connect to ubus
Configuring getrandom.
Configuring jshn.
Configuring ubi-utils.
Configuring ubox.
Configuring fstools.
Configuring base-files.
sysctl: error setting key 'vm.min_free_kbytes': Read-only file system
/etc/rc.common: line 32: can't create /proc/sys/net/ipv6/conf/default/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/all/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/br-lan/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/default/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/eth0/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/lan1/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/lan2/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/lo/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/wan/accept_ra: Read-only file system
sysctl: error setting key 'kernel.panic': Read-only file system
sysctl: error setting key 'kernel.core_pattern': Read-only file system
sysctl: error setting key 'fs.suid_dumpable': Read-only file system
sysctl: error setting key 'fs.protected_hardlinks': Read-only file system
sysctl: error setting key 'fs.protected_symlinks': Read-only file system
sysctl: error setting key 'net.ipv4.conf.default.arp_ignore': Read-only file system
sysctl: error setting key 'net.ipv4.conf.all.arp_ignore': Read-only file system
sysctl: error setting key 'net.ipv4.ip_forward': Read-only file system
sysctl: error setting key 'net.ipv4.icmp_echo_ignore_broadcasts': Read-only file system
sysctl: error setting key 'net.ipv4.icmp_ignore_bogus_error_responses': Read-only file system
sysctl: error setting key 'net.ipv4.igmp_max_memberships': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_fin_timeout': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_keepalive_time': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_syncookies': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_timestamps': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_sack': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_dsack': Read-only file system
sysctl: error setting key 'net.ipv6.conf.default.forwarding': Read-only file system
sysctl: error setting key 'net.ipv6.conf.all.forwarding': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_acct': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_checksum': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_max': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_tcp_timeout_established': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_udp_timeout': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_udp_timeout_stream': Read-only file system
/etc/rc.common: eval: line 23: can't create /proc/sys/kernel/hostname: Read-only file system
Failed to connect to ubus
Failed to connect to ubus
sysctl: error setting key 'vm.min_free_kbytes': Read-only file system
/etc/rc.common: line 32: can't create /proc/sys/net/ipv6/conf/default/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/all/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/br-lan/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/default/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/eth0/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/lan1/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/lan2/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/lo/accept_ra: Read-only file system
/etc/rc.common: line 34: can't create /proc/sys/net/ipv6/conf/wan/accept_ra: Read-only file system
sysctl: error setting key 'kernel.panic': Read-only file system
sysctl: error setting key 'kernel.core_pattern': Read-only file system
sysctl: error setting key 'fs.suid_dumpable': Read-only file system
sysctl: error setting key 'fs.protected_hardlinks': Read-only file system
sysctl: error setting key 'fs.protected_symlinks': Read-only file system
sysctl: error setting key 'net.ipv4.conf.default.arp_ignore': Read-only file system
sysctl: error setting key 'net.ipv4.conf.all.arp_ignore': Read-only file system
sysctl: error setting key 'net.ipv4.ip_forward': Read-only file system
sysctl: error setting key 'net.ipv4.icmp_echo_ignore_broadcasts': Read-only file system
sysctl: error setting key 'net.ipv4.icmp_ignore_bogus_error_responses': Read-only file system
sysctl: error setting key 'net.ipv4.igmp_max_memberships': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_fin_timeout': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_keepalive_time': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_syncookies': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_timestamps': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_sack': Read-only file system
sysctl: error setting key 'net.ipv4.tcp_dsack': Read-only file system
sysctl: error setting key 'net.ipv6.conf.default.forwarding': Read-only file system
sysctl: error setting key 'net.ipv6.conf.all.forwarding': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_acct': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_checksum': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_max': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_tcp_timeout_established': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_udp_timeout': Read-only file system
sysctl: error setting key 'net.netfilter.nf_conntrack_udp_timeout_stream': Read-only file system
Configuring dnsmasq.
Failed to connect to ubus
Failed to connect to ubus
Failed to connect to ubus
Configuring libjson-script.
Configuring procd.
Configuring firewall.
Warning: Failed to connect to ubus
Warning: Unable to locate ipset utility, disabling ipset support
Warning: Section @zone[0] (lan) cannot resolve device of network 'lan'
Warning: Section @zone[1] (wan) cannot resolve device of network 'wan'
Warning: Section @zone[1] (wan) cannot resolve device of network 'wan6'
 * Populating IPv4 filter table
   * Rule 'Allow-DHCP-Renew'
   * Rule 'Allow-Ping'
   * Rule 'Allow-IGMP'
   * Rule 'Allow-IPSec-ESP'
   * Rule 'Allow-ISAKMP'
   * Forward 'lan' -> 'wan'
   * Zone 'lan'
   * Zone 'wan'
 * Populating IPv4 nat table
   * Zone 'lan'
   * Zone 'wan'
 * Populating IPv4 mangle table
   * Zone 'lan'
   * Zone 'wan'
 * Populating IPv6 filter table
   * Rule 'Allow-DHCPv6'
   * Rule 'Allow-MLD'
   * Rule 'Allow-ICMPv6-Input'
   * Rule 'Allow-ICMPv6-Forward'
   * Rule 'Allow-IPSec-ESP'
   * Rule 'Allow-ISAKMP'
   * Forward 'lan' -> 'wan'
   * Zone 'lan'
   * Zone 'wan'
 * Populating IPv6 mangle table
   * Zone 'lan'
   * Zone 'wan'
 * Set tcp_ecn to off
   ! Unable to write value: Read-only file system
 * Set tcp_syncookies to on
   ! Unable to write value: Read-only file system
 * Set tcp_window_scaling to on
   ! Unable to write value: Read-only file system
 * Running script '/etc/firewall.user'
Failed to connect to ubus
Configuring odhcp6c.
Configuring uci.
Configuring dropbear.
Failed to connect to ubus
Configuring mtd.
Configuring urandom-seed.
Failed to connect to ubus
Configuring ppp.
Configuring logd.
Failed to connect to ubus
Configuring ppp-mod-pppoe.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-reject6:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-flow:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-lib-crc-ccitt:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-pppoe:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-pppox:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ipt-conntrack:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-reject:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * resolve_conffiles: Existing conffile /etc/group is different from the conffile in the new package. The new conffile will be placed at /etc/group-opkg.
 * resolve_conffiles: Existing conffile /etc/passwd is different from the conffile in the new package. The new conffile will be placed at /etc/passwd-opkg.
 * resolve_conffiles: Existing conffile /etc/shadow is different from the conffile in the new package. The new conffile will be placed at /etc/shadow-opkg.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-nat:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * check_data_file_clashes: Package libnl-tiny1 wants to install file /usr/lib/libnl-tiny.so
	But that file is already provided by package  * libnl-tiny
 * resolve_conffiles: Existing conffile /etc/config/dhcp is different from the conffile in the new package. The new conffile will be placed at /etc/config/dhcp-opkg.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-ipt:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ip6tables:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * resolve_conffiles: Existing conffile /etc/dropbear/dropbear_rsa_host_key is different from the conffile in the new package. The new conffile will be placed at /etc/dropbear/dropbear_rsa_host_key-opkg.
 * check_data_file_clashes: Package libnl-tiny1 wants to install file /usr/lib/libnl-tiny.so
	But that file is already provided by package  * libnl-tiny
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-leds-gpio:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-gpio-button-hotplug:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ipt-core:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ppp:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-conntrack:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-ipt6:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-nf-conntrack6:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ipt-offload:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-slhc:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ipt-nat:
 * 	kernel (= 5.4.81-1-d6569c402c086a58a5ff4ed4d48c8727)
xargs: opkg: exited with status 255; aborting
root@OpenWrt:~# opkg install luci
Installing luci (git-20.074.84698-ead5e81) to root...
Downloading https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/luci_git-20.074.84698-ead5e81_all.ipk
wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ledtrig-default-on found, but incompatible with the architectures configured
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ledtrig-heartbeat found, but incompatible with the architectures configured
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ledtrig-netdev found, but incompatible with the architectures configured
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ledtrig-timer found, but incompatible with the architectures configured
 * opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/luci/luci_git-20.074.84698-ead5e81_all.ipk, wget returned 1.
 * opkg_install_pkg: Failed to download luci. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package luci.

Now even opkg update fails with multiple *** Failed to download the package list from ... errors.

1 Like

LAN and WAN should use different subnets:
https://openwrt.org/docs/guide-user/network/openwrt_as_routerdevice

https://openwrt.org/faq/cannot_satisfy_dependencies

https://openwrt.org/meta/infobox/upgrade_packages_warning

2 Likes

Ok, so first of all I would like to try the latest snaphsot available just in case that helps with the upgrade and luci installation. I've carefully checked that my model says "model R4A" in its sticker and Gigabit 4A in the box, and comparing all available, very similar models, I downloaded the sysupgrade image from here ( Xiaomi Mi Router 4A Gigabit Edition (4A Gigabit / R3Gv2)). When I try to flash it I get:

Device xiaomi,mir3g-v2 not supported by this image
Supported devices: xiaomi,mir3g-v2 - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA

But that web states clearly 4A Gigabit / R3Gv2. So that one should be the right image, right? I also followed the instructions on OpenWRTInvasion to build an image for this model using the last source, but the built image yields the same message. What am I missing?

From the device page:

The hardware is identical to the OpenWrt Xiaomi R3G v2. But.!! different bootloader, don't use 4A-Giga firmware on R3Gv2

What does ubus call system board say?

2 Likes

Yes, I read that, but then on the description of that link:

Warning: Not to be confused with the similarly looking (and identically named) R3Gv2 which lacks USB, has just 16MiB SPI flash, 128MiB RAM. The R3Gv2 is now widely sold as the Xiaomi 4A Gigabit edition and offered with Chinese or Global (English) firmware. OpenWrt support was added in October 2019.

Mine is the one that lacks USB, but that last link links back to the 4A Gigabit website. The results:

{
	"kernel": "5.4.43",
	"hostname": "OpenWrt",
	"system": "MediaTek MT7621 ver:1 eco:3",
	"model": "Xiaomi Mi Router 3G v2",
	"board_name": "xiaomi,mir3g-v2",
	"release": {
		"distribution": "OpenWrt",
		"version": "SNAPSHOT",
		"revision": "r13499-7b4877c204",
		"target": "ramips/mt7621",
		"description": "OpenWrt SNAPSHOT r13499-7b4877c204"
	}
}
1 Like

Evidently you have the r3g-v2.
Can you verify the flash and ram size? free; df -h

1 Like

It seems so, but that is the image that was giving errors. And, also, 128 Mb of ram.

              total        used        free      shared  buff/cache   available
Mem:         121968       17884       92076        6040       12008       71468
Swap:             0           0           0
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 1.5M      1.5M         0 100% /rom
tmpfs                    59.6M      5.9M     53.7M  10% /tmp
/dev/mtdblock10          10.8M    424.0K     10.4M   4% /overlay
overlayfs:/overlay       10.8M    424.0K     10.4M   4% /
tmpfs                   512.0K         0    512.0K   0% /dev

And the weirdness of the version mismatch:

Device xiaomi,mir3g-v2 not supported by this image
Supported devices: xiaomi,mir3g-v2

It's the same! Why it says not supported then?

Ok, so these are the different, but similar models:

  • R 4A Gigabit edition: supported
  • R 3G v2, usually sold as R 4A Gigabit edition (mine). Same hardware, different bootloader: not yet supported?
  • R 3G v1: more powerful, supported.

From the OpenWRT R3G site:

The R3Gv2 is now widely sold as the Xiaomi 4A Gigabit edition and offered with Chinese or Global (English) firmware. OpenWrt support was added in October 2019.

But the table with the available snapshots is empty for R3Gv2. So I don't get if it is supported or not.

There is a snapshot image in the page however read carefully the warnings and the procedure if you decide to try it.

3 Likes

That is the firmware that is yielding the message:

Device xiaomi,mir3g-v2 not supported by this image
Supported devices: xiaomi,mir3g-v2 - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA

Is there something I'm missing?

Edit: some guys have told me here that the wiki links are not working, and that I should use this image with the force flag. I'm going to try.

Most likely not, it seems already a troublesome router. Maybe a search for similar topics in the forum will provide you some help.

3 Likes

Maybe this topic will give you some hints.

3 Likes

Yes, that's the link I posted in the edit to my last message. I can confirm the link they provided me with there works.

Aha, I didn't click it. So best of luck with your router!

2 Likes