Can't join a scanned network

Hi All,

I am trying to just connect to a scanned network. It is a phone hotspot that for some reason when it requests the name of the network, it defaults to wwan. I have left it like that and then tried clicking submit, but it won't do anything but put a red box around the name of the network. Even if I enter the name of the wifi network or change it to anything else, it will not connect to this network.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
"kernel": "4.9.120",
	"hostname": "OpenWrt",
	"system": "Qualcomm Atheros QCA9533 ver 2 rev 0",
	"model": "GL.iNet GL-AR300M",
	"board_name": "gl-ar300m",
	"release": {
		"distribution": "OpenWrt",
		"version": "18.06.1",
		"revision": "r7258-5eb055306f",
		"target": "ar71xx\/generic",
		"description": "OpenWrt 18.06.1 r7258-5eb055306f"
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd1b:2f19:7f55::/48'

config interface 'lan'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR300M-ed0'
	option ipaddr '192.168.1.1'

config device 'lan_dev'
	option name 'eth1'
	option macaddr '*********'

config interface 'wan'
	option type 'bridge'
	udhcpc_opts -t 0 -T 2 -A 3
	option ifname 'eth0 bat0'
	option proto 'dhcp'
	option hostname 'GL-AR300M-ed0'
	option metric '10'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config interface 'bat0_hardif_wlan'
	option mtu '1560'
	option proto 'batadv'
	option mesh 'bat0'
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd1b:2f19:7f55::/48'

config interface 'lan'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR300M-ed0'
	option ipaddr '192.168.1.1'

config device 'lan_dev'
	option name 'eth1'
	option macaddr '********'

config interface 'wan'
	option type 'bridge'
	udhcpc_opts -t 0 -T 2 -A 3
	option ifname 'eth0 bat0'
	option proto 'dhcp'
	option hostname 'GL-AR300M-ed0'
	option metric '10'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config interface 'bat0_hardif_wlan'
	option mtu '1560'
	option proto 'batadv'
	option mesh 'bat0'
root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca953x_wmac'
	option htmode 'HT20'
	option noscan '1'
	option country 'US'
	option disabled '0'
	option legacy_rates '1'
	option channel '1'
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca953x_wmac'
	option htmode 'HT20'
	option noscan '1'
	option country 'US'
	option disabled '0'
	option legacy_rates '1'
	option channel '1'

root@OpenWrt:~# cat /etc/config/dhcp 

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'
config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall 
config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	********
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		********
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	*******
#	option src_mac	*******
#	option src_port	80
#	option dest		wan
#	option dest_ip	******
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	*******
#	option src_mac	*******
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	*******
#	option dest_port	120
#	option proto	tcp



It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

Forgive me if I am wrong but I always thought spaces were not allowed in network names

1 Like

Spaces are allowed in SSIDs, but not in OpenWrt network interface names.

However, all bets are off here because the OP is using a vendor fork based on a very old (EOL, unsupported) version of OpenWrt. The AR300m is supported by official OpenWrt 23.05, so the user should install that -- it may resolve the issue right away, or if not we can help here when an official (and modern) version is in use.

Like implied in the discussion, the WiFi SSID is a different thing that the internal network name in OpenWrt network config.
Network name can't include spaces, so the validation in LuCI fails like your screenshot shows.
But the network name can easily be wwan (if that is still unused in your config), and the SSID that you join has its own name.

Actually, the word "network" is used for two different purposes on that page, creating confusion. In the page title it refers to the WiFi network (SSID), while in the network name config item it refers name used in config for netifd etc.

Haven't yet checked, but I guess that our normal LuCI has quite the same thing on that page, and might need editing, as the page is apparently confusing.

EDIT:
Seems to be:

1 Like

The info under the offending dialogue box says "Allowed characters are A-Z a-z 0-9 and _" spaces therefore are not allowed

That is true. Also the length of the name is limited to 15 characters, the first character must be a letter, etc. Though uppercase is alllowed, by convention only lowercase is used. This is especially an issue with LuCI which in some places will uppercase or lowercase names destroying the case distinction.

There's little reason to change the network name from the default of wwan (Wireless Wide Area Network, i.e. a connection to the Internet that is wireless).

While the ambiguity of the work 'network' (as pointed out by @hnyman) exists in the latest official OpenWrt, it is important to revisit the fact that the OP is using a vendor fork based on the long EOL/unsupported 18.06.

@dewo3276 - you should install the 23.05.2 from the official project.

I added a clarification to the page on the current OpenWrt:

1 Like

To clarify: I have tried typing in a network name without the spaces. It doesn't matter spaces or not. The reason I put spaces in there is because that is how the network name appears from my phone that I named: "Duster Buster". It doesn't seem to like it. These ARM routers have been cast aside for years so me updating to the latest official build will probably rectify some errors.