Can't install Luci


I have a tp-link archer c6 router. I installed openwrt snapshot. I need luci, but i can't install.
I tried following:
opkg update
opkg install luci

this is the result:

root@OpenWrt:~# opkg install luci
Installing luci (git-19.359.63125-8362ab8-1) to root...
Installing libubox20170601 (2019-11-24-07413cce-1) to root...
Collected errors:
 * check_data_file_clashes: Package libubox20170601 wants to install file /lib/
	But that file is already provided by package  * libubox20191226
 * opkg_install_cmd: Cannot install package luci.

Can anyone help me, what made i wrong?

Someone just got this exact error:

Not much that you can do than wait (or build the image by yourself).

libubox was updated yesterday and the new version is contained in the firmware images (created by the phase1 buildbot for ath79), but other optional packages (like luci) are compiled separately by the phase2 buildbot (for mips_24kc), and there the new build run is not yet completed, so the known packages list differs from the phase1 results. (depedency list claims an older version of libubox than the one that you already have in the image itself)


I have the same problem.
What do you mean with :

In a situation like this, you flash the current snapshot - then install all needed packages at once

How can I do this?

Regards Hans

I mean:

  1. Flash the current snapshot
  2. Install packages
  3. Done!

You mean to install a newer version?

I just installed openwrt-ramips-mt7621-netgear_wndr3700-v5-squashfs-factory
last week on my netgear wndr3700.

(sorry I am a bit new to this)

Regards Hans

Yes. When using snapshot, you must install all packages needed, usually within 24 hours. Snapshots are updated daily.


I solved my problem by building the image by myself, as hnyman suggested.

The image, that I builded includes luci, so I didn't need it to install by opkg.

You have had bad luck in timing, as there have been recent commits breaking the compatibility to the situation week ago.

You need to reinstall new firmware and packages.
(and like lleachii says, it is best to install additional packages quickly after installing the firmware, so that everything are compatible)

Thanks all,
One additional question.
I have the Netgear WNDR3700 v5.
In the list there is a column for install URL, Upgrade URL, Snapshot install URL and Snapshot upgrade URL.
I have loaded openwrt-ramips-mt7621-netgear_wndr3700-v5-squashfs-factory.bin to install openwrt.
Do I now need to use openwrt-ramips-mt7621-netgear_wndr3700-v5-squashfs-sysupgrade.bin for the upgrade?

Regards Hans

*-factory.bin = installing OpenWrt from stock firmware
*-sysupgrade.bin = upgrading, when OpenWrt is already installed

1 Like


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.