Cant install in xiaomi 4a

mediatek mt7603en
other one said M15T1G1664A
mediatek mt7612en

The flash chip is the 8 legged chip located near the DC power socket.

Correction DC socket, not WAN socket.


I think you looked at wrong component. Please recheck.


My bad, it's the chip near power Socket
with red dot.


1 Like

i edited the numbers

22.03 will install without problem.

PCB shows manufacture date stamp 2034. Possibly, Week 34 of 2020?

What does manufacture date on barcode label attached to cardboard shipping box quote for my curiosity?

22.03.0-rc6 this one right?

production date 05/2020

1 Like

Yes, use sysupgrade.bin file.

im trying the .bat method, the 1st pass the backup bat doesnt work said telenet isnt working

Is pc connected with ethernet to R4A?

Did you reset router to default settings?

Is R4a Connected to internet?

Wrong password used at 0.start_main.bat?

Is R4a brand new?

pc to a switch, router WAN to the same switch, nothing connect to LAN, is configured as acces point repeater with cable right now

You have to follow instructions exactly as per pdf guide. I never tried it in AP mode.

Perhaps AP mode is cause of original problem described in your first post?

ie. Factory reset router. PC to LAN, WAN to internet.

1 Like

OMG done thanks, i default everything, move from WAN to LAN after configurate and run perfect

1 Like

Please mark topic as solved.

Device page updated to include 'reset router' step.

If you have seen '0.start_main.bat', it is OK.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.