Can't install any ipk package


Newly installed:

Powered by LuCI openwrt-22.03 branch (git-22.288.45147-96ec0cd) / OpenWrt 22.03.2 r19803-9a599fee93
Hostname OpenWrt
Model TP-Link TL-MR3020 v3
Architecture MediaTek MT7628AN ver:1 eco:2
Target Platform ramips/mt76x8
Firmware Version OpenWrt 22.03.2 r19803-9a599fee93 / LuCI openwrt-22.03 branch git-22.288.45147-96ec0cd
Kernel Version 5.10.146

I can't install any ipk package located at /tmp directory and I receive below message:

opkg install usbutils_014-1_mips_24kc.ipk
opkg install /tmp/usbutils_014-1_mips_24kc.ipk

Unknown package 'usbutils'.
Collected errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for usbutils found, but
    incompatible with the architectures configured
  • opkg_install_cmd: Cannot install package usbutils

I tried with different packages and I each time got the same error message from CLI or within LuCI.

As far as I know, I installed a Stable firmware. I collected ipk packages from same version, under packages directory. I'm waiting for your help. Thank you. Regads.

Safak Kayhan

Is there any particular reason to try to install the package manually?

Do you see any errors containing pkg_hash_check_unresolved: cannot find dependency?

Are the dependencies installed?

Package: usbutils
Version: 014-1
Depends: libc, libusb-1.0-0, libudev, librt, libpthread
1 Like

Hi, thank you for your reply.

I generally try to download the softwares/packages to local and then test off-line, harden if necessary, then put on internet. This is my general attitude toward installation procedures. So, in fact, I didn't open this new router to internet yet.

I tried many other ipk packages from CLI or LuCI. None of them seem to even start to be installed. Even the dependency packages can not be installed.

I'm looking for your further comments and help. Regards.

Safak Kayhan

Should probably do

opkg update
opkg install usbutils

But it'd require internet.

1 Like

Hi, thank you for your reply.

If OpenWrt package installation would depend on internet solely, it would be stated at documentation I think. Furthermore it wouldn't be necessary to share package library for download on website.

Let's assume I connected the device to the internet and updated / installed packages. Doing so, will I be able to download packages and install manually later locally or will I always be dependable to internet connection?

Thank you for your contribution in advance. Regards.

Safak Kayhan

You need internet to DL them to local storage too, don't you?

You should never update packages.

If you clone the whole package repository, you shouldn't need internet.

1 Like

Read this and try local repo:

1 Like


Thank you for your replies. Regards.

Safak Kayhan

What is the output of cat /etc/opkg/distfeeds.conf ?


Yes if you're going to download packages manually, they have to be obtained from the repository matching your OpenWrt version. As @trendy said, the base URLs are in the feeds configuration file.

Other options to make an offline installation-- instead of installing packages one at a time use Image Builder or build from source.


Hi, thank you for your replies.

Requested output is below:

</>cat /etc/opkg/distfeeds.conf</>
</>src/gz openwrt_core</>
</>src/gz openwrt_base</>
</>src/gz openwrt_luci</>
</>src/gz openwrt_packages</>
</>src/gz openwrt_routing</>
</>src/gz openwrt_telephony</>


Safak Kayhan

You are trying to install mips_24kc when you need mipsel_24kc
You are downloading packages from the wrong directory.


This is the compatible usbutils, however as @mk24 mentioned, it is smarter to build the image rather than manually download and install packages post installation.

Hi, thank you very much for the solution.

Device: TL-MR3020 V3.20
Target: ramips
Package Architecture: mipsel_24kc

I downloaded necessary packages and could install easily. Now sda and sda1 are listed under dev directory.

Safak Kayhan

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.