Can't get to cable modem's UI

I've scoured the forums here and the internet for a working solution, to no avail.

I want to get to http://192.168.100.1 which is the address for my modem's user interface. I'm connected via ethernet with just the OpenWrt router in between.

The modem is a Surfboard 8200 (SB8200). I've already tried creating a "modem" interface in OpenWrt and manually assigning it IP address 192.168.100.2. I've also previously tried creating a static route.

Nothing I've tried so far works. Anybody got a suggestion?

Normally, nothing is required to get this to work on a typical OpenWrt install with a wan that is configured with DHCP.

Let's see your config:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
{
        "kernel": "6.1.86",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "GL.iNet GL-MT3000",
        "board_name": "glinet,gl-mt3000",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r25933-cab2e1de0d",
                "target": "mediatek/filogic",
                "description": "OpenWrt SNAPSHOT r25933-cab2e1de0d"
        }
}
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '[redacted]'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '192.168.0.1'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'
        option peerdns '0'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'

config interface 'modem'
        option proto 'static'
        option device '@wan'
        option ipaddr '192.168.100.2'
        option netmask '255.255.255.0'
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '11'
        option band '2g'
        option htmode 'HE40'
        option cell_density '0'
        option country 'US'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '[redacted]'
        option encryption 'sae-mixed'
        option key '[redacted]'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '161'
        option band '5g'
        option htmode 'HE40'
        option cell_density '0'
        option country 'US'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '[redacted]'
        option encryption 'sae-mixed'
        option key '[redacted]'
config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'modem'
        list network 'wan'
        list network 'wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

Thank you for helping!

You should probably using a stable release build unless there is a reason you are using snapshot.
https://firmware-selector.openwrt.org/?version=23.05.3&target=mediatek%2Ffilogic&id=glinet_gl-mt3000
Remove this:

reboot and try again.

Removed this:

rebooted, and it's still a no-go

Should note that I've had this problem ever since starting to use OpenWrt; stable or SNAPSHOT doesn't matter, it's always been this way for me. I've tried it on two different PCs and a laptop as well.

I was always able to get to the cable modem interface on my old routers (a Linksys E3000 and later a TP-Link Archer A10)

can you ping 192.168.100.1?

Pinging 192.168.100.1 with 32 bytes of data:
Reply from 192.168.100.1: bytes=32 time=5ms TTL=63
Reply from 192.168.100.1: bytes=32 time=2ms TTL=63
Reply from 192.168.100.1: bytes=32 time=2ms TTL=63
Reply from 192.168.100.1: bytes=32 time=2ms TTL=63

Ping statistics for 192.168.100.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 2ms, Maximum = 5ms, Average = 2ms

This indicates the traffic is being routed properly... but the admin interface is not responding via the web. And... it seems that you're not alone:

https://www.reddit.com/r/HomeNetworking/comments/lnpwi9/cannot_access_arris_sb8200_admin_page/

No resolution in that thread, but seems to suggest that this is an issue related to the SB8200 and not the routers.

1 Like

Mmmh, maybe they are 0laying silly ttl games with http/http access. Can you hook up a computer directly to the modem and get a packetcapture?

that's what I was afraid of and found similar no-solutions around the web

wonder if it's something they've broken since the time I was able to do it, or if it is only broken on some routers like OpenWrt but not others? ugh...

thank you very much for looking into it, guess I'll wait until I get a new cable modem, or upgrade to fiber

I think it's been broken on your SB8200 since you got it... making a guess here, maybe the last time you may have bothered to access the interface of your cable modem was with a cable modem model that you had owned previously?

I don't think it's OpenWrt specific, though... but you could always flash your router back to the factory firmware if you fancy a test to confirm or refute my hypothesis.

I got the SB8200 in 2019 along with a TP-Link Archer A10, and it did work at that time. It just hasn't worked since I switched to an OpenWrt router (in Jan 2023), but it seems it was coincidental in timing with whatever Arris/Comcast may have broken on the modem itself.

What happens if you connect a computer directly to the modem (with fixed IP address of 198.168.100.2)? Can you access the admin page? If yes, please take a packet capture of a configuration session and check whether the modem plays silly TTL games (setting the TTL field to 1)...

This looks about right, except I would have used:
option device '@eth0'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.