Can't get IP from single SSID on 2.4Ghz and 5Ghz Wi-Fi network

I can't get a single SSID on 2.4Ghz and 5Ghz Wi-Fi network to give me an IP address.

If i disable either one of the Wi-Fi interfaces, I am able to get an IP address.

Any idea on what I could be doing wrong?

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option htmode 'HT20'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'

config wifi-iface
    option  device      'radio1'
    option  mode        'ap'
    option  ssid        'Frankie'
    option  network     'testnet'
    option  encryption  'none'
    option  key         'none'

config wifi-iface
    option  device      'radio0'
    option  mode        'ap'
    option  ssid        'Frankie'
    option  network     'testnet'
    option  encryption  'none'
    option  key         'none'

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdb1:055d:e375::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option ipaddr '192.168.142.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option force_link '1'

config interface 'wan'
    option proto 'dhcp'

config interface 'wan6'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '2 0t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '3 0t'

config interface 'testnet'
    option force_link '1'
    option _orig_ifname 'wlan1-1'
    option _orig_bridge 'false'
    option proto 'static'
    option ipaddr '172.20.0.1'
    option netmask '255.255.0.0'

config interface 'vpn'
    option ifname 'tun0'
    option defaultroute '0'
    option peerdns '0'
    option proto 'none'

/etc/config/dhcp

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/testnet/'
    option domain 'testnet'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf'
    option localservice '1'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option dhcpv6 'server'
    option ra 'server'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'testnet'
    option start '100'
    option limit '150'
    option interface 'testnet'
    option leasetime '1h'

I think it should be the same as your 2.4G and 5G SSID, please modify the name of the different SSID.

Both Wi-Fi interfaces have the same SSID.

network>>wifi
2.4G SSID:LEDE_2.4G
5G SSID:LEDE_5G

It appears that adding option type 'bridge' to the testnet network interface in /etc/config/network made it work.

Could anyone explain why this made the difference?

@jow I got the hint from a post you made on the OpenWrt forum. Maybe you could shed some light?

I want the 2.4Ghz and 5Ghz interfaces to have the same SSID, not different SSIDs.