Can't get a connection - HG612 Modem - D7800 Router

Hello, I'm having issues getting wan connected. I'm using the HG612 unlocked modem connected to the WAN port of the D7800 (as the built in modem isn't supported).

OpenWRT version: OpenWrt 19.07.4 r11208-ce6496d796

ISP: Vodafone UK

I can connect perfectly fine on the stock D7800 firmware with the following settings:

This is the log in OpenWRT when it attempts to connect (this just loops):

I've tried various ways of setting the connection up but none of them have worked so far.

These are the current settings I'm using:

I'm probably missing something very obvious but I'm completely lost here.
Any help would be greatly appreciated, thanks!

The HG612 handles the vlan 101 tagging for you. Do not set it up on the D7800. (On other routers such as Home Hub 5A, the WAN port physical interface is called eth0.2. It may be different for D7800)

Suggest returning openwrt on your netgear to default settings.

Did you try just setting up PPPoE details before you started editing the switch configuration?

What is default switch configuration? (I don't own a D7800)
ie. post your default /etc/config/network file

1 Like

Hi, thanks for the suggestion. I ended up giving up, I had spent hours and hours trying every different thing I could think of(including what you suggested but I ended up trying it again to be sure) in the config but I'd always get the same error.

I ended up buying a WRT1900ACS and I got it set up in 5 minutes using identical settings I was using on the D7800 and it's connecting just fine now.

Not sure what the issue could have been.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.