Can't flash MikroTik hAP lite rb941-2nd

I'm trying to flash the hAP lite but I'm stuck at sysupgrade command.
I've successfully booted via tftp and can access the web gui and ssh into the router.

But installing the squashfs-sysupgrade.bin always fails. On the web gui it just never completes and doesn't throw any error. Via ssh I get the following message:

root@OpenWrt:~# sysupgrade -n /tmp/openwrt-19.07.3-ar71xx-mikrotik-rb-nor-flash-16M-squashfs-sysupgrade.bin 
Commencing upgrade. Closing all shell sessions.

Any help would be appreciated.

I'm having a similar problem with a MikroTik RB951G 2HnD.
When I try to flash it with the sysupgrade command it doesn't give an error but just reboots and then it is loading the RouterOS again.
I believe that it is caused by the RouterOS version because this device had the v6.46.4 and I also have a brand new device with v6.44.5 and that one worked without any problems so OpenWRT is running on that one.

I tried to downgrade the original firmware but I couldn't downgrade below v.6.46.1 with the same result not accepting the OpenWRT bin file