Can't flash LEDE on Linksys EA3500

I can't seem to flash LEDE (kirkwood/audi....factory.bin) to my EA3500, the flash seems to be successful in the sense that I never get any messages saying it failed, but it always boots back into stock firmware. I tried rolling back to Linksys "classic" firmware (as opposed to the "smart firmware) and flashing from that just to see if it would make a difference, but still no luck, just wondering if anyone had any ideas, thanks.

Update - OpenWrt flashes fine from factory and LEDE flashes fine from OpenWrt, I've only been running LEDE for a few hours now, but no problems so far, seems to be working fine (other than not flashing from factory of course).

Sounds like a bug to me. I would have posted it to so it does not get lost in the forum.

I can confirm this is still the case in April 24

Here it is July 11th and the problem is still the same for the factory.bin Is there a fix?

The bug is still open:
FS#505 - Can't install LEDE on Linksys EA3500

Vote on the bug to raise the attention of the main LEDE devs.

I see that if flashing the snapshot openwrt squashfs-factory.bin then going to in the lede-squashfs-sysupgrade.tar would work, but does that mean wifi isn't installed from the a thread on installing lede ea3500? I guess that might mean even though using the image builder and will get the same as the initial problem getting lede to flash the ea3500?

Just adding to my reply, I followed the suggested instructions from the another post lede install EA3500 I think or something like and was able to get mine flashed as well, thanks to all who put their minds and hardware together for a positive outcome but that still leaves the initial issue with the the lede-squashfs-factory.bin for this device, I'll definitely keep an eye out for some response from the devs.

It's been over a month is there a problem with factory.bin for the linksys still? On a different note, for testing purposes I went back to oem to check if there some issue with how the router was not responding well to a arris tm1602a telephony and now I can't install either openwrt or lede again? That just stinks now I'm up stream without a paddle unless I can manage to ask someone if they ever solder some copper wire the size of a breakaway header pin to serial a substitution for the real thing?

I flashed a ea4500 straight from stock couple weeks ago with a trunk build and it was fine.

ea3500 is largely the same as ea4500 except for an underclocked processor and half the ram + flash.

Whats the current status of your ea3500? Can it boot into linksys stock?

Yes it can boot into stock, i was able to flash back but now I'm unable to flash the original openwrt linksys audi squashfs factory bin image or the current lede audi squashfs factory bin for some reason, what happens the system would just hang after 8 mins and just stops responding and I would have to recover with holding the reset button back into stock firmware only try a few more times with openwrt and lede factory images. I also reset to defaults during each of those flashing since I get locked out. I guess maybe have to resort to connecting to serial and flashing that way, not sure why its not allowing me to flash the openwrt or lede factory images? Right now i'm stuck using stock firmware will have to take down the linksys but on a day when I'm here alone, my family would have be upset for me to take down the connection for who knows how long, know what I mean?

The more recent lede compatible linksys routers all got dual partitions. Some things you can try:

Let's call the current partition you boot up p1, and the other partition p2. When you boot stock firmware on p1, it flashes to p2.

p2 partition could have problem, in this case we want:

  1. Try booting up with p2 and see if it would work by using "restore firmware" which just set the boot environment to the other partition. (on p2 it sets to p1, on p1 it sets to p2)
  2. Or just reflash p2 with a slightly older/newer version of stock. See if it boots up

Then you can try flashing lede on p1 (while booted on p2) or p2 (while booted on p1).

If even flashing stock firmware did not work you are gonna need a serial flash.

Sorry for such a late response. I really didn't have a problem getting back to oem, but I can't install Lede or openwrt factory.bin image. Originally I had used the openwrt factory image and was able to get things started then install the sysupgrade tar image. Maybe the partition 2 is damaged, I really don't know and I don't any breakaway header pins. Such a bummer not sure if this able to be reflash with open source without using a serial I guess? I see you are mentioning a two step process by booting into partition 2 but I assume this being done with a serial connection in which i dont have setup. I have to wait to purchase the breakaway pins and solder, such a hassle to get open source placed back on now after trying and using the gui but as i mentioned using the the openwrt factory image just kills or softbricks linksys while the lede factory images just reboot back into linksys. I haven't tried the older firmware for linksys yet and may give it a try and write back with some information. Thanks for your feed back and suggestions, one freeman

linksys firmware allows you to "restore to previous firmware". You don't need a serial connection yet.

As I mentioned, you can either force the router to boot in the alternate partition (by "restore to previous firmware", please google how you can do this), or flash a different version of firmware and let the router automatically boot to the alternate partition after a successful flash.

I'll search for said method look over the info and will post my findings as the outcome, and thank you again kyva1929, I'll have to do maybe do this tomorrow since i have my family home, i have only a open window of such time to myself in order to do some tech stuff to the network. Will post as I soon as I can.

I restored defaults, installed the .SSA image, and once up restored defaults, rebooted.(maybe not necessary to restore defaults each time but useful)then I tried the release version for lede first and it failed it, basically rebooted back into linksys, next tried the lede and openwrt trunk versions with the same results, it was with the openwrt factory bin image, size was 4.9 it then allowed to load onto the 2nd partition, then I was able to continue through ssh, setup passwd, followed through to install luci-ssh and proceeded to login to luci-ssh, go to install lede sysupgrade tar image configure my network settings, run a the network reload command. The lede image sizes are just a little bigger than the openwrt factory bin image, but not sure of that, I have ran my own lede compilation image yet in order to confirm that issue, other what I am placing here what worked to get lede reinstalled. Thank you for suggestion and reply kyva1929

I am not totally sure if I understood you, is this what you did?

  1. On partition 1 with stock Linksys firmware, you flashed stock firmware to (supposedly) partition 2.
  2. You restored defaults - is this default setting, or restore "previous firmware"?
  3. Assuming you did restore default setting in step 2, so you are on partition 2.
  4. Then you tried 1st) lede release 2nd) lede trunk and 3rd) openwrt trunk, all of which failed to boot and simply bring you back to Linksys stock.
  5. Then you tried 4th) openwrt factory bin image, and it succeeded.

Just in case this may be helpful to other people:
Can you clarify for the 1st) 2nd) and 3rd) attempt you tried flashing the ***kirkwood-linksys-audi-squashfs-factory.bin version?
Which image did you flash with 4th) for the one which you succeeded? Can you give a link?

Sorry I may had too coffee at the time. To start off, I restored the defaults on the linksys and roll back the firmware to once i was up i did a restore to defaults, then once back up i first tried the lede-kirkwood-linksys-audi-squashfs-factory.bin(release version&snapshot not in that order) however those images didn't work I didn't try the openwrt snapshot just released a few days ago, but I had the openwrt-kirkwood-linksys-audi-squashfs-factory.bin saved back from July that worked still, the only difference is that size of it is 4.7Mib compared to the lede-kirkwood-linksys-audi-squashfs-factory.bin image 5.7Mib
I personally wouldn't mind to check or inspect it more closely to what is the main difference and why one version works as opposed the other doesn't, but this the only router that is working and I have a family that needs the internet access, maybe when i have time or if someone else may take on this task.

Stock Firmware Version: 1.1.40 (Build 162464)

Sorry for resurrecting an old thread, but this is still a problem as of Thu Jan 25 14:05:46 PST 2018.
I've downloaded the BIN from verified hash; followed installation instructions as outlined on The firmware upgrade process completed successfully and the router rebooted. After reboot the firmware remained stock not LEDE. Following I restored the defaults according to manufacturer's user manual and tried to re-flash LEDE. Same results. Did the last step once more (restore defaults) and again same results.
Could someone from the devs please respond and suggest a fail-safe methodology on how to successfully flash LEDE?


Stock Firmware Version

I rolled back to an earlier version of stock firmware. Same results.


I'm not a dev, but you can try flashing an OpenWrt trunk build, they used to work but it's been a while since i've tried one, then you can flash LEDE from OpenWrt. If you try OpenWrt and it doesn't work, i have an OpenWrt trunk build saved from November that i know works, i can put it in a Dropbox and you can use it if you want.

edit - keep in mind that trunk builds don't have Luci

I've downloaded openwrt-kirkwood-linksys-audi-squashfs-factory from and flashed. Now the GUI is broken at Maybe wrong BIN? It did flash to OpenWRT though as I can connect via ssh.

Confirmed hash prior to flash.