Can't flash LEDE on EAP120 EU version, error "bad file"

Trying to install LEDE 17.01.1 from here to the Tp-link EAP120, hardware 1.0, EU-version. The Web-GUI freaks out with "bad file" error. Tried to remove the dots in the file name as mentioned here, didn't help. So apparently this is because the LEDE image is for US version? I tried to compare files for Archer C7, which has both "US" and "EU" versions of the LEDE 17.01.1 file, but the image header looks completely different to that of EAP120. I can copy&paste HEX, but have no idea to which direction to go and do not want to brick the AP. Help appreciated! Thanks

Could you try to downgrade to firmware EAP120(UN)_V1_160107 using TFTP recovery method ? Do not try to downgrade using the interface, you will get the same error.

If you success downgrading, then there are good chances that this old firmware will accept LEDE afterwards.

Thanks DjiPi, i could not figure out if EAP120 has TFTP server or the client. Tried both, with a switch. No mention of port 69 in neither direction in Tcpdump.

You did not get any offer like this?

ARP Who has 192.168.x.x? Tell 192.168.y.y

Also, I've seen that you could have a console port, is that true?
Console port cable description from TP-Link:

Could not find an offer like that. I would have soldered the cable only if i was desperate enough. Since i had another device compatible with LEDE, i left the EAP120(EU) with the stock firmware. Thanks for help anyway.