Can't flash Archer A7

Hi guys, I just bought TP-Link Archer A7 v5 and it doesn't wanna flashing. It has original firmware version 1.0.7 Build 20181218. I tried to flash it trough tftp like said here;a=commit;h=1e4ee63cc8d1889a78b539a5ed7be8d56e9b976f

I have laptop with Arch Linux. And here my steps

  1. I set up netctl config to static IP for ethernet adapter
  2. Installed tftp-hpa, started tftpd service
  3. Put openwrt-19.07.0-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin renamed to ArcherC7v5_tp_recovery.bin into /srv/tftp directory
  4. Connected router to laptop
  5. Pressed reset button then turned router on and holding reset 5-7 seconds and waited ~150 seconds

And no result at all. I tried also connect Archer to laptop trough my old router with same effect. And I tried update to openwrt to web ui. Didn't work too.
I see in wireshark file request via tftp and data blocks transferring but router still has stock firmware

Did I something wrong? Or device just don't accept new firmware. Maybe I should change router to Archer C7 before it's too late.

I think both devices are overpriced if you bought them me. Limited storage space and the CPU isn't that good either. C7 was really a great device in the past, but it's an old one now.

If you have other options to replace, people could help you to choose one.

1 Like

I have not many options. So first I want to know it's possible to flash Archer A7 or I should return it.
Maybe I shouldn't mention C7 in this particular topic at all.

1 Like

Well, A7 is almost the same specs and therefore it's also overpriced.

OK. But what about main topic?

I don't own that model. I have C7, so I can't be very specific about A7.

However, if you see in Wireshark that the router requested the file, and you also see it being transferred in tftp-hpa (or whatever TFTP server you would use), then it's difficult to know why the router isn't accepting the image without making a serial connection (which would void the warranty, so not a good idea if you are considering returning it).

I can't think of anything else, unless the following is a typo, and it was supposed to be A7 (but then I think it wouldn't have downloaded the file if the name was wrong?)

Did you try waiting for longer, in case the flashing is taking long time?

You could also try emailing the author of the post on the page you referenced.

Initially try to rename factory file into something shorter, like 'f.bin' and upgrade via Web-Interface.

I'm pretty sure file name is correct. It's what all instruction says. And it's exact name requested by router via tftp.

Yes. I waited 3-5 minutes. And I guess web interface shouldn't work if router still flashing. But it worked.

I tried it. Web interface said "wrong file type" and rejected it.

Can you try official stock image?

Do you meant upgrade with official image?

Yes, how it works in upgrade in Web-Interface, or in tftp. Start with tftp.

I'll try it. But it's OK to use image intended for upgrading like recovery with tftp? They are the same?

You should use 'factory' image to work with 'stock' firmware.

Do you talking about openwrt 'factory'. Because I asking about this:

Like I understood I should go to TP-Link site. Then go to support page. Download firmware update and put it in /srv/tftp and so on. Right? So I worried if it's OK.

Yes, exactly. Stock image is only single.

Well, TP-Link image flashed successfully with tftp

OK, it is interesting. Compare sizes of stock image and 'factory' OpenWRT. Is there 18.06.X version for your router?

Stock image is 14.8 Mb and OpenWRT is 4.3 Mb.

Nope. First image available since 19.07.0-rc1

'factory' image should have the same size, as stock one (e.g. it takes place for another router C5 V1, C7 V2). But for another models of TP-Link it really differs. So it is question to developers.