Can't create a 5GHz Wireless network that is visible for my phone

Hi, I have compiled and installed OpenWRT/LEDE from coolsnowwolf but I cannot create a Wireless network visible for my phone.
I have to say that in the previous stock firmware I was able to do this, 5GHz without any problem, what should I do for achieve this again?
Thanks in advance.

A lot more information is necessary if you want help...

First, what router are you using? What specific version of OpenWrt (it sounds like you're not using an official version, so it is possible that there could be some differences relative to the official version that may affect our ability to help).

Let's also see your configuration:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Also, what phone are you using? And what version of its OS?

Thanks, I have this config and in fact I am using an unofficial version of OpenWRT, the device is a Xiaomi AX3600.
I leave all the info you requested to me.
ubus call system board

{
	"kernel": "5.10.100",
	"hostname": "OpenWrt",
	"system": "ARMv8 Processor rev 4",
	"model": "Xiaomi AX3600",
	"board_name": "xiaomi,ax3600",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "SNAPSHOT",
		"target": "ipq807x/generic",
		"revision": "R22.2.2",
		"description": "OpenWrt "
	}
}

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd29:e704:fdc0::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1 eth2 eth3'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config interface 'VPN'
	option ifname 'ipsec0'
	option proto 'static'
	option ipaddr '10.10.10.1'
	option netmask '255.255.255.0'

config interface 'Kairos'
	option proto 'dhcp'
	option type 'bridge'

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/20000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option txpower '30'
	option legacy_rates '1'
	option mu_beamformer '0'
	option country 'CN'
	option channel '165'
	option htmode 'VHT80'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key 'Eleftheria159'
	option ieee80211k '1'
	option ieee80211v '1'
	option time_advertisement '0'
	option ssid 'SSID-0'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/20000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option txpower '30'
	option legacy_rates '1'
	option mu_beamformer '0'
	option country 'CN'
	option channel '165'
	option htmode 'VHT80'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key 'Eleftheria159'
	option ieee80211k '1'
	option ieee80211v '1'
	option time_advertisement '0'
	option ssid 'SSID-0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi'
	option channel '36'
	option band '5g'
	option country 'US'
	option disabled '0'
	option legacy_rates '1'
	option mu_beamformer '0'
	option txpower '30'
	option htmode 'VHT160'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/c000000.wifi+1'
	option channel '1'
	option band '2g'
	option mu_beamformer '0'
	option distance '100'
	option htmode 'HE40'
	option country 'CN'
	option legacy_rates '0'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option mode 'ap'
	option encryption 'none'
	option ssid 'OpenWrt-ALT'
	option network 'Kairos lan'

config wifi-iface
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option network 'lan'

cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option noresolv '0'

config dhcp 'lan'
	option interface 'lan'
	option limit '150'
	option leasetime '12h'
	option start '2'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config srvhost
	option srv '_vlmcs._tcp'
	option target 'OpenWrt'
	option port '1688'
	option class '0'
	option weight '100'

config domain

cat /etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option fullcone '0'
	option flow_offloading '0'
	option flow_offloading_hw '0'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 Kairos'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

config include 'zerotier'
	option type 'script'
	option path '/etc/zerotier.start'
	option reload '1'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config include 'qcanssecm'
	option type 'script'
	option path '/etc/firewall.d/qca-nss-ecm'
	option family 'any'
	option reload '1'

config include 'ipsecd'
	option type 'script'
	option path '/etc/ipsec.include'
	option reload '1'

config rule 'ike'
	option name 'ike'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'udp'
	option dest_port '500'

config rule 'ipsec'
	option name 'ipsec'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'udp'
	option dest_port '4500'

config rule 'ah'
	option name 'ah'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'ah'

config rule 'esp'
	option name 'esp'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'esp'

config zone 'VPN'
	option name 'VPN'
	option input 'ACCEPT'
	option forward 'ACCEPT'
	option output 'ACCEPT'
	option network 'VPN'

config forwarding 'vpn'
	option name 'vpn'
	option dest 'wan'
	option src 'VPN'

config include 'mia'
	option type 'script'
	option path '/etc/mia.include'
	option reload '1'

config include 'unblockmusic'
	option type 'script'
	option path '/var/etc/unblockmusic.include'
	option reload '1'

config rule 'kms'
	option name 'kms'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'tcp'
	option dest_port '1688'

You appear to have a mixture of country codes -- US and CN. Be sure to set the correct code for your location.

Try using VTHT40 (instead of 80), and try channel 163.

Turn off 802.11v and 802.11k -- not all client devices are happy with these standards.

In your radio2 configuration, remove the Kairos network (just leave it as lan only), or if this is an uplink, remove lan.

If you are using a wireless uplink, be sure to set the radio on auto channel selection.

1 Like

Edit 1: I changed the country code to Bolivia, the country where I live, but I was not able to change the channel to 163(it was not available) so I changed it to 161.

Thanks a lot, It was a matter of country code configuration, now the three Wireless interfaces are visible in my phone.
I have to clarify that k and v standards did not affected in any way, of course I have enable them knowing nothing about them, but now everything is working as was intended, I have a lot to learn.
Thanks again.

Your post does not appear to be related to an officially released OpenWrt version, package or supported operation.

It is unlikely that you will receive useful input here.

Please seek advise from the relevant maintainer.

This is particular relevant in this case, as these forks are based on the QSDK with a partially proprietary kernel and entirely different wireless drivers, hostapd and driver configuration, than the efforts under development for OpenWrt would use (ath11k, normal OpenWrt/ upstream'ish hostapd) - all bets are off.

@psherman gave me an awesome answer, with that I was able to do what I was doing. If you let me I would be pleased that I can do more questions on this forum.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.