Cant connect to WIFI on new VLAN , wired connection works

OpenWrt 23.05.0-rc3 r23389-5deed175a5
TP-Link Archer C7 v4

I created a vlan 3

The "wan" port is the connection to the main router (all so Openwrt)

I created a new interface

interface

I can attach a device to port 'lan 2' and it works perfectly . gets a 10.10.20.n address

I created a new wifi

I cannot connect to the new wifi instance.
If I move the new wifi instance to "lan" works

This has to be something simple

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

BTW this is on an AP

root@kitten:~# ubus call system board
{
        "kernel": "5.15.127",
        "hostname": "kitten",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link Archer C7 v4",
        "board_name": "tplink,archer-c7-v4",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.0-rc3",
                "revision": "r23389-5deed175a5",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05.0-rc3 r23389-5deed175a5"
        }
}
root@kitten:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd52:a3e1:a96b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        option vlan_filtering '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list ip6class 'local'
        option ipaddr '10.10.10.8'
        option gateway '10.10.10.1'
        list dns '10.10.10.1'
        list dns_search 'evinrude.net'

config device
        option name 'eth0.2'
        option macaddr ''

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 4 5 1'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 3 1t'
        option vid '3'

config device
        option type 'bridge'
        option name 'br-lan3'
        list ports 'eth0.3'
        option bridge_empty '1'

config interface 'lan3'
        option proto 'static'
        option device 'br-lan3'
        option ipaddr '10.10.20.3'
        option netmask '255.255.255.0'
        option gateway '10.10.10.1'

config bridge-vlan
        option device 'br-lan3'
        option vlan '3'
        option local '0'
        list ports 'eth0.3:t'

root@kitten:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option country 'US'
        option cell_density '0'
        option htmode 'VHT80'
        option txpower '21'
        option channel '136'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key '****'
        option ssid 'kitten5'
        option disassoc_low_ack '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option country 'US'
        option cell_density '0'
        option channel '11'
        option txpower '21'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key '****'
        option skip_inactivity_poll '1'
        option disassoc_low_ack '0'
        option ssid 'kitten24'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid 'kittenAV5'
        option encryption 'psk2'
        option key '****'
        option network 'lan3'

root@kitten:~# cat /etc/config/dhcp

config dnsmasq
        option localise_queries '1'
        option rebind_protection '1'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option ednspacket_max '1232'
        option cachesize '2000'
        list notinterface 'lan'
        option domain ' '
        list rebind_domain 'evinrude.net'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'
        option dynamicdhcp '0'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option name 'kitten'
        option ip '10.10.10.2'

config dhcp 'lan3'
        option interface 'lan3'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option ignore '1'

root@kitten:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config include
        option path '/etc/firewall.user'

You're mixing swconfig and DSA syntax in a way that will nto work. Also, your VLAN3 network doesn't need an address.

Remove the vlan_filtering option from this section:

Then, delete this section:

And finally, edit your lan3 network interface to look like this:

config interface 'lan3'
        option proto 'none'
        option device 'br-lan3'

Also, delete this:

Restart your router after making these changes and test again.

3 Likes

I translated what you said into "dude,you've got it all screwed up" . So I reverted my config to before I started this exercise and started over . 5 minutes later its working . I'm not sure what I did the first time .

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.